]> code.ossystems Code Review - openembedded-core.git/commitdiff
automake: finish updating to 1.10, move some content between files to clean up
authorMarcin Juszkiewicz <hrw@openedhand.com>
Thu, 20 Mar 2008 13:10:38 +0000 (13:10 +0000)
committerMarcin Juszkiewicz <hrw@openedhand.com>
Thu, 20 Mar 2008 13:10:38 +0000 (13:10 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@4105 311d38ba-8fff-0310-9ca6-ca027cbcb966

meta/packages/automake/automake-native.inc
meta/packages/automake/automake.inc
meta/packages/automake/automake_1.10.bb

index 7b69252ff0a00519e452cb7a3c750e81c58c685d..8b64af309a35f4cefe4d85817d6272adde0ec51b 100644 (file)
@@ -1,5 +1,5 @@
-SECTION = "devel"
-include automake_${PV}.bb
+require automake.inc
+
 DEPENDS = "autoconf-native"
 RDEPENDS_automake-native = "autoconf-native perl-native-runtime"
 
index fa59c1f5cc40f2609cb73c7be4add3f40915c8ff..ab2edf26bc927cd27e5ddc7e7c75421bf5103d43 100644 (file)
@@ -1,23 +1,16 @@
-RDEPENDS_automake += "\
-    autoconf \
-    perl \
-    perl-module-bytes \
-    perl-module-constant \
-    perl-module-cwd \
-    perl-module-data-dumper \
-    perl-module-dynaloader \
-    perl-module-errno \
-    perl-module-exporter-heavy \
-    perl-module-file-basename \
-    perl-module-file-compare \
-    perl-module-file-copy \
-    perl-module-file-glob \
-    perl-module-file-spec-unix \
-    perl-module-file-stat \
-    perl-module-getopt-long \
-    perl-module-io \
-    perl-module-io-file \
-    perl-module-posix \
-    perl-module-strict \
-    perl-module-text-parsewords \
-    perl-module-vars "
+DESCRIPTION = "A tool for automatically generating Makefiles."
+LICENSE = "GPL"
+HOMEPAGE = "http://www.gnu.org/software/automake/"
+SECTION = "devel"
+FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/automake-${PV}"
+PR = "r1"
+
+SRC_URI = "${GNU_MIRROR}/automake/automake-${PV}.tar.bz2 "
+
+S = "${WORKDIR}/automake-${PV}"
+
+inherit autotools
+
+export AUTOMAKE = "${@bb.which('automake', bb.data.getVar('PATH', d, 1))}"
+
+FILES_${PN} += "${datadir}/automake* ${datadir}/aclocal*"
index 1235c1096341a27704d13a6e7150de816253aa26..4c54d069ca416aba6cb957164cf3e2e463ed2f2f 100644 (file)
@@ -1,29 +1,38 @@
-DESCRIPTION = "A tool for automatically generating Makefiles."
-LICENSE = "GPL"
-HOMEPAGE = "http://www.gnu.org/software/automake/"
-SECTION = "devel"
-
-SRC_URI = "${GNU_MIRROR}/automake/automake-${PV}.tar.bz2 \
-       ${@['file://path_prog_fixes.patch;patch=1', ''][bb.data.inherits_class('native', d)]}"
-
-S = "${WORKDIR}/automake-${PV}"
-
-FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/automake-${PV}"
-
-inherit autotools
+require automake.inc
 
-export AUTOMAKE = "${@bb.which('automake', bb.data.getVar('PATH', d, 1))}"
-FILES_${PN} += "${datadir}/automake* ${datadir}/aclocal*"
+RDEPENDS_automake += "\
+    autoconf \
+    perl \
+    perl-module-bytes \
+    perl-module-constant \
+    perl-module-cwd \
+    perl-module-data-dumper \
+    perl-module-dynaloader \
+    perl-module-errno \
+    perl-module-exporter-heavy \
+    perl-module-file-basename \
+    perl-module-file-compare \
+    perl-module-file-copy \
+    perl-module-file-glob \
+    perl-module-file-spec-unix \
+    perl-module-file-stat \
+    perl-module-getopt-long \
+    perl-module-io \
+    perl-module-io-file \
+    perl-module-posix \
+    perl-module-strict \
+    perl-module-text-parsewords \
+    perl-module-vars "
 
-require automake.inc
+SRC_URI += "file://path_prog_fixes.patch;patch=1"
 
 do_install () {
        oe_runmake 'DESTDIR=${D}' install
        install -d ${D}${datadir}
        if [ ! -e ${D}${datadir}/aclocal ]; then
-               ln -sf aclocal-1.9 ${D}${datadir}/aclocal
+               ln -sf aclocal-1.10 ${D}${datadir}/aclocal
        fi
        if [ ! -e ${D}${datadir}/automake ]; then
-               ln -sf automake-1.9 ${D}${datadir}/automake
+               ln -sf automake-1.10 ${D}${datadir}/automake
        fi
 }