]> code.ossystems Code Review - openembedded-core.git/commitdiff
libxml2: patch for CVE-2012-2871
authorScott Garman <scott.a.garman@intel.com>
Thu, 27 Dec 2012 17:53:08 +0000 (09:53 -0800)
committerScott Garman <scott.a.garman@intel.com>
Thu, 27 Dec 2012 17:57:23 +0000 (09:57 -0800)
the patch come from:
http://src.chromium.org/viewvc/chrome/trunk/src/third_party/libxml/ \
src/include/libxml/tree.h?r1=56276&r2=149930

libxml2 2.9.0-rc1 and earlier, as used in Google Chrome before
21.0.1180.89, does not properly support a cast of an unspecified
variable during handling of XSL transforms, which allows remote
attackers to cause a denial of service or possibly have unknown other
impact via a crafted document, related to the _xmlNs data structure in
include/libxml/tree.h.

http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2012-2871

[YOCTO #3580]
[ CQID: WIND00376779 ]

Signed-off-by: Li Wang <li.wang at windriver.com>
This fixes denzil bug [YOCTO #3648]

Signed-off-by: Scott Garman <scott.a.garman@intel.com>
meta/recipes-core/libxml/libxml2/libxml2-CVE-2012-2871.patch [new file with mode: 0644]
meta/recipes-core/libxml/libxml2_2.8.0.bb

diff --git a/meta/recipes-core/libxml/libxml2/libxml2-CVE-2012-2871.patch b/meta/recipes-core/libxml/libxml2/libxml2-CVE-2012-2871.patch
new file mode 100644 (file)
index 0000000..41b19d0
--- /dev/null
@@ -0,0 +1,36 @@
+libxml2 CVE-2012-2871
+
+the patch come from:
+http://src.chromium.org/viewvc/chrome/trunk/src/third_party/libxml/src \
+/include/libxml/tree.h?r1=56276&r2=149930
+
+libxml2 2.9.0-rc1 and earlier, as used in Google Chrome before 21.0.1180.89,
+does not properly support a cast of an unspecified variable during handling
+of XSL transforms, which allows remote attackers to cause a denial of service
+or possibly have unknown other impact via a crafted document, related to the
+_xmlNs data structure in include/libxml/tree.h.
+
+http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2012-2871
+
+Upstream-Status: Pending
+
+Signed-off-by: Li Wang <li.wang@windriver.com>
+---
+ include/libxml/tree.h |    1 +
+ 1 files changed, 1 insertions(+), 0 deletions(-)
+
+diff --git a/include/libxml/tree.h b/include/libxml/tree.h
+index b733589..5422dda 100644
+--- a/include/libxml/tree.h
++++ b/include/libxml/tree.h
+@@ -351,6 +351,7 @@ struct _xmlNs {
+     struct _xmlNs  *next;     /* next Ns link for this node  */
+     xmlNsType      type;      /* global or local */
+     const xmlChar *href;      /* URL for the namespace */
++    const char *dummy_children;       /* lines up with node->children */
+     const xmlChar *prefix;    /* prefix for the namespace */
+     void           *_private;   /* application data */
+     struct _xmlDoc *context;          /* normally an xmlDoc */
+-- 
+1.7.0.5
+
index fe9ec0526b31c35bd02e3cb2d6f80196d88738d8..f2790b3b76227cd5d05ea321c23c4431f4434df7 100644 (file)
@@ -1,6 +1,8 @@
 require libxml2.inc
 
-PR = "r1"
+PR = "r2"
 
 SRC_URI[md5sum] = "c62106f02ee00b6437f0fb9d370c1093"
 SRC_URI[sha256sum] = "f2e2d0e322685193d1affec83b21dc05d599e17a7306d7b90de95bb5b9ac622a"
+
+SRC_URI += "file://libxml2-CVE-2012-2871.patch"