]> code.ossystems Code Review - openembedded-core.git/commitdiff
libfm: split the gtk+ bindings into their own package
authorMax Krummenacher <max.oss.09@gmail.com>
Sat, 27 Jan 2018 13:56:32 +0000 (14:56 +0100)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 29 Jan 2018 08:49:45 +0000 (08:49 +0000)
Recipes depending on libfm with the gtk+ bindings will automatically rdepend
additionally on the new package libfm-gtk.

Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-support/libfm/libfm_1.2.5.bb

index 1ddddfdc990a9226902d667cf904694ebb11cb6c..6844243c1e308e49f458e516b96c417c04e86cac 100644 (file)
@@ -24,7 +24,19 @@ EXTRA_OECONF = "--with-gtk=3"
 
 do_configure[dirs] =+ "${S}/m4"
 
+PACKAGES =+ "libfm-gtk"
 PACKAGES += "${PN}-mime"
+FILES_libfm-gtk = " \
+    ${libdir}/libfm-gtk*so.* \
+    ${libdir}/libfm/modules/gtk* \
+    ${bindir}/libfm-pref-apps \
+    ${bindir}/lxshortcut \
+    ${datadir}/applications/libfm-pref-apps.desktop \
+    ${datadir}/applications/lxshortcut.desktop \
+    ${datadir}/libfm/images/folder.png \
+    ${datadir}/libfm/images/unknown.png \
+    ${datadir}/libfm/ui/*.ui \
+"
 FILES_${PN}-mime = "${datadir}/mime/"
 
 do_install_append () {