]> code.ossystems Code Review - openembedded-core.git/commitdiff
netbase: fix check for nfsroot in if-pre-up.d script
authorPaul Eggleton <paul.eggleton@linux.intel.com>
Fri, 29 Apr 2011 09:33:32 +0000 (10:33 +0100)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 3 May 2011 23:49:51 +0000 (00:49 +0100)
The if-pre-up.d/nfsroot script was no longer functioning correctly due to
a change in iproute2's installation of the "ip" executable. The script will
now function correctly regardless of whether ip is in /bin or /sbin.

Fixes [YOCTO #1006].

Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
meta/recipes-core/netbase/netbase-4.45/nfsroot
meta/recipes-core/netbase/netbase_4.45.bb

index fc384a8ea5704e85e38dfebba9162d094a8813a2..750c0a98f9c3e88ed1177d0a1a7b71adddef8f0f 100644 (file)
@@ -27,7 +27,7 @@ exec 0<&9 9<&-
 
 test $nfsroot -eq 0 && exit 0
 
-if test -x /sbin/ip ; then
+if [ -x /bin/ip -o -x /sbin/ip ] ; then
     nfs_iface=`ip route get $nfs_addr | grep dev | sed -e 's/^.*dev \([-a-z0-9.]*\).*$/\1/'`
 fi
 
index 68cde857ec356304e91b83d62204b790fab52602..319afa7bd228bb9820b74f82aa743dcc46a1860c 100644 (file)
@@ -4,7 +4,7 @@ HOMEPAGE = "http://packages.debian.org/netbase"
 SECTION = "base"
 LICENSE = "GPLv2"
 LIC_FILES_CHKSUM = "file://debian/copyright;md5=3dd6192d306f582dee7687da3d8748ab"
-PR = "r0"
+PR = "r1"
 
 inherit update-rc.d