]> code.ossystems Code Review - openembedded-core.git/commitdiff
Add xev
authorRoss Burton <ross@openedhand.com>
Wed, 28 Mar 2007 16:10:50 +0000 (16:10 +0000)
committerRoss Burton <ross@openedhand.com>
Wed, 28 Mar 2007 16:10:50 +0000 (16:10 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@1407 311d38ba-8fff-0310-9ca6-ca027cbcb966

meta/packages/xorg-app/xev/diet-x11.patch [new file with mode: 0644]
meta/packages/xorg-app/xev_X11R7.0-1.0.1.bb [new file with mode: 0644]

diff --git a/meta/packages/xorg-app/xev/diet-x11.patch b/meta/packages/xorg-app/xev/diet-x11.patch
new file mode 100644 (file)
index 0000000..7e93f16
--- /dev/null
@@ -0,0 +1,74 @@
+--- xev/xev.c  2004-02-06 11:00:37.000000000 -0800
++++ xev/xev.new.c      2005-08-04 15:40:36.000000000 -0700
+@@ -149,7 +149,7 @@
+     nbytes = XLookupString (e, str, 256, &ks, NULL);
+     /* not supposed to call XmbLookupString on a key release event */
+-    if (e->type == KeyPress && xic) {
++    /*if (e->type == KeyPress && xic) {
+         do {
+             nmbbytes = XmbLookupString (xic, e, buf, bsize - 1, &ks, &status);
+             buf[nmbbytes] = '\0';
+@@ -159,7 +159,7 @@
+                 buf = realloc (buf, bsize);
+             }
+         } while (status == XBufferOverflow);
+-    }
++    }*/
+     if (ks == NoSymbol)
+       ksname = "NoSymbol";
+@@ -189,7 +189,7 @@
+     }
+     /* not supposed to call XmbLookupString on a key release event */
+-    if (e->type == KeyPress && xic) {
++    /*if (e->type == KeyPress && xic) {
+         printf ("    XmbLookupString gives %d bytes: ", nmbbytes);
+         if (nmbbytes > 0) {
+            dump (buf, nmbbytes);
+@@ -200,7 +200,7 @@
+         printf ("    XFilterEvent returns: %s\n", 
+                 XFilterEvent (eventp, e->window) ? "True" : "False");
+-    }
++    }*/
+ }
+ static void
+@@ -857,7 +857,7 @@
+         fprintf (stderr, "%s:  XSetLocaleModifiers failed\n", ProgramName);
+     }
+-    xim = XOpenIM (dpy, NULL, NULL, NULL);
++    /*xim = XOpenIM (dpy, NULL, NULL, NULL);
+     if (xim == NULL) {
+         fprintf (stderr, "%s:  XOpenIM failed\n", ProgramName);
+     }
+@@ -884,7 +884,7 @@
+             }
+             XFree (xim_styles);
+         }
+-    } 
++    }*/
+     screen = DefaultScreen (dpy);
+@@ -948,7 +948,7 @@
+       printf ("Outer window is 0x%lx, inner window is 0x%lx\n", w, subw);
+     }
+-    if (xim && xim_style) {
++    /*if (xim && xim_style) {
+         xic = XCreateIC (xim, 
+                          XNInputStyle, xim_style, 
+                          XNClientWindow, w, 
+@@ -958,7 +958,7 @@
+         if (xic == NULL) {
+             fprintf (stderr, "XCreateIC failed\n");
+         }
+-    }
++    }*/
+     for (done = 0; !done; ) {
+       XEvent event;
diff --git a/meta/packages/xorg-app/xev_X11R7.0-1.0.1.bb b/meta/packages/xorg-app/xev_X11R7.0-1.0.1.bb
new file mode 100644 (file)
index 0000000..1ecd45b
--- /dev/null
@@ -0,0 +1,8 @@
+require xorg-app-common.inc
+
+DESCRIPTION = "X Event Viewer"
+LICENSE = "MIT"
+
+DEPENDS += " virtual/libx11"
+
+SRC_URI += "file://diet-x11.patch;patch=1"