]> code.ossystems Code Review - openembedded-core.git/commitdiff
gzip: fix MakeMaker issues with using wrong SHELL/GREP
authorJackie Huang <jackie.huang@windriver.com>
Fri, 21 Nov 2014 09:50:57 +0000 (04:50 -0500)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Fri, 5 Dec 2014 17:43:14 +0000 (17:43 +0000)
A set of substitution is being processed to all target scripts with sed by
replacing some key words with the detected values at configure time, this
is exactly not compliant with cross compling, and will cause missing path
errors at run time like:
"/usr/bin/zgrep: line 230: /usr/bin/grep: No such file or directory"

Fixed by removing unneeded substitution and using real runtime paths
instead.

Signed-off-by: Ming Liu <ming.liu@windriver.com>
Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
Signed-off-by: Jackie Huang <jackie.huang@windriver.com>
Signed-off-by: Ross Burton <ross.burton@intel.com>
meta/recipes-extended/gzip/gzip-1.6/wrong-path-fix.patch [new file with mode: 0644]
meta/recipes-extended/gzip/gzip.inc

diff --git a/meta/recipes-extended/gzip/gzip-1.6/wrong-path-fix.patch b/meta/recipes-extended/gzip/gzip-1.6/wrong-path-fix.patch
new file mode 100644 (file)
index 0000000..92863d6
--- /dev/null
@@ -0,0 +1,31 @@
+fix MakeMaker issues with using wrong SHELL/GREP
+
+A set of substitution is being processed to all target scripts with sed by
+replacing some key words with the detected values at configure time, this
+is exactly not compliant with cross compling, and will cause missing path
+errors at run time like:
+"/usr/bin/zgrep: line 230: /usr/bin/grep: No such file or directory"
+
+Fixed by removing unneeded substitution and using real runtime paths
+instead.
+
+Signed-off-by: Ming Liu <ming.liu@windriver.com>
+
+Upstream-Status: Pending
+
+Index: gzip-1.3.12/Makefile.am
+===================================================================
+diff -urpN a/Makefile.am b/Makefile.am
+--- a/Makefile.am      2013-11-30 10:06:09.402234871 +0800
++++ b/Makefile.am      2013-11-30 10:13:42.952236025 +0800
+@@ -81,9 +81,8 @@ gzip.doc.gz: gzip.doc $(bin_PROGRAMS)
+ SUFFIXES = .in
+ .in:
+       $(AM_V_GEN)sed \
+-              -e 's|/bin/sh|$(SHELL)|g' \
+               -e 's|[@]bindir@|'\''$(bindir)'\''|g' \
+-              -e 's|[@]GREP@|$(GREP)|g' \
++              -e 's|[@]GREP@|$(base_bindir)/grep|g' \
+               -e 's|[@]VERSION@|$(VERSION)|g' \
+               $(srcdir)/$@.in >$@-t \
+         && chmod a+x $@-t \
index 671b1eb16a684daddfc3e417cc627abd63c222b3..b90856e796bec06b69f5f3150a904984fe99e7f9 100644 (file)
@@ -9,6 +9,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504 \
                     file://gzip.h;beginline=8;endline=20;md5=6e47caaa630e0c8bf9f1bc8d94a8ed0e"
 
 SRC_URI = "${GNU_MIRROR}/gzip/${BP}.tar.gz"
+SRC_URI_append_class-target = " file://wrong-path-fix.patch"
 
 inherit autotools texinfo