]> code.ossystems Code Review - openembedded-core.git/commitdiff
Add scrolled window placement fixing patch
authorRoss Burton <ross@openedhand.com>
Mon, 23 Jul 2007 14:49:30 +0000 (14:49 +0000)
committerRoss Burton <ross@openedhand.com>
Mon, 23 Jul 2007 14:49:30 +0000 (14:49 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@2209 311d38ba-8fff-0310-9ca6-ca027cbcb966

meta/packages/gtk+/gtk+-2.10.12/scrolled-placement.patch [new file with mode: 0644]
meta/packages/gtk+/gtk+_2.10.12.bb

diff --git a/meta/packages/gtk+/gtk+-2.10.12/scrolled-placement.patch b/meta/packages/gtk+/gtk+-2.10.12/scrolled-placement.patch
new file mode 100644 (file)
index 0000000..09ded53
--- /dev/null
@@ -0,0 +1,35 @@
+Index: gtk/gtkscrolledwindow.c
+===================================================================
+--- gtk/gtkscrolledwindow.c    (revision 18493)
++++ gtk/gtkscrolledwindow.c    (working copy)
+@@ -885,7 +885,7 @@
+   if (GTK_IS_SCROLLED_WINDOW (widget))
+     {
+       gtk_scrolled_window_update_real_placement (GTK_SCROLLED_WINDOW (widget));
+-      gtk_widget_queue_draw (widget);
++      gtk_widget_queue_resize (widget);
+     }
+   else if (GTK_IS_CONTAINER (widget))
+     gtk_container_forall (GTK_CONTAINER (widget), traverse_container, NULL);
+Index: gdk/x11/gdksettings.c
+===================================================================
+--- gdk/x11/gdksettings.c      (revision 18493)
++++ gdk/x11/gdksettings.c      (working copy)
+@@ -65,7 +65,8 @@
+   "Xft/RGBA\0"                "gtk-xft-rgba\0"
+   "Xft/DPI\0"                 "gtk-xft-dpi\0"
+   "Net/FallbackIconTheme\0"   "gtk-fallback-icon-theme\0"
+-  "Gtk/TouchscreenMode\0"     "gtk-touchscreen-mode\0";
++  "Gtk/TouchscreenMode\0"     "gtk-touchscreen-mode\0"
++  "Gtk/ScrolledWindowPlacement\0" "gtk-scrolled-window-placement\0";
+ static const struct
+ {
+@@ -107,5 +108,6 @@
+   { 1197, 1206 },
+   { 1219, 1227 },
+   { 1239, 1261 },
+-  { 1285, 1305 }
++  { 1285, 1305 },
++  { 1326, 1354 }
+ };
index 5bb3a842945a6e07da800d7722406a4c04f0b757..4c0e63fcf1efd154b7029384ba4dda06e6e04245 100644 (file)
@@ -1,7 +1,7 @@
 require gtk+.inc
 
 DEPENDS += "cairo"
-PR = "r7"
+PR = "r9"
 
 # disable per default - untested and not all patches included.
 DEFAULT_PREFERENCE = "-1" 
@@ -13,7 +13,6 @@ SRC_URI = "ftp://ftp.gtk.org/pub/gtk/v2.10/gtk+-${PV}.tar.bz2 \
            file://gtklabel-resize-patch;patch=1 \
            file://menu-deactivate.patch;patch=1 \
            file://xsettings.patch;patch=1 \
-           file://scroll-timings.patch;patch=1 \
            file://small-gtkfilesel.patch;patch=1 \
            file://migration.patch;patch=1;pnum=0 \
            file://run-iconcache.patch;patch=1 \
@@ -21,7 +20,9 @@ SRC_URI = "ftp://ftp.gtk.org/pub/gtk/v2.10/gtk+-${PV}.tar.bz2 \
            file://hardcoded_libtool.patch;patch=1 \
            file://no-demos.patch;patch=1 \
         file://cellrenderer-cairo.patch;patch=1;pnum=0 \
-        file://entry-cairo.patch;patch=1;pnum=0"
+        file://entry-cairo.patch;patch=1;pnum=0 \
+        file://scrolled-placement.patch;patch=1;pnum=0"
+#           file://scroll-timings.patch;patch=1 \
 #           file://pangoxft2.10.6.diff;patch=1"
 #           file://gtk+-handhelds.patch;patch=1
 #         file://single-click.patch;patch=1