]> code.ossystems Code Review - openembedded-core.git/commitdiff
qemu-0.9.1: Remove hacky patch and call configure correctly
authorRichard Purdie <richard@openedhand.com>
Wed, 9 Apr 2008 22:12:29 +0000 (22:12 +0000)
committerRichard Purdie <richard@openedhand.com>
Wed, 9 Apr 2008 22:12:29 +0000 (22:12 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@4222 311d38ba-8fff-0310-9ca6-ca027cbcb966

meta/packages/qemu/qemu-0.9.1/disable-error-in-configure.patch [deleted file]
meta/packages/qemu/qemu_0.9.1.bb

diff --git a/meta/packages/qemu/qemu-0.9.1/disable-error-in-configure.patch b/meta/packages/qemu/qemu-0.9.1/disable-error-in-configure.patch
deleted file mode 100644 (file)
index 017f9f6..0000000
+++ /dev/null
@@ -1,17 +0,0 @@
----
- configure |    2 --
- 1 file changed, 2 deletions(-)
-
-Index: qemu/configure
-===================================================================
---- qemu.orig/configure        2007-12-03 16:38:38.000000000 +0000
-+++ qemu/configure     2007-12-03 16:38:39.000000000 +0000
-@@ -323,8 +323,6 @@ for opt do
-   ;;
-   --disable-werror) werror="no"
-   ;;
--  *) echo "ERROR: unknown option $opt"; show_help="yes"
--  ;;
-   --disable-nptl) nptl="no"
-   ;;
-   esac
index 164296b0d41001eea08762f57e34c671a2b8cfbd..a51e437f77c1df6f0e3d15737db21e368350a935 100644 (file)
@@ -1,6 +1,6 @@
 LICENSE = "GPL"
 DEPENDS = "zlib"
-PR = "r7"
+PR = "r8"
 
 FILESPATH = "${FILE_DIRNAME}/qemu-${PV}"
 FILESDIR = "${WORKDIR}"
@@ -33,7 +33,6 @@ SRC_URI = "\
     file://fix_segfault.patch;patch=1 \
     file://writev_fix.patch;patch=1 \
     file://configure_symlinkpath_fix.patch;patch=1 \
-    file://disable-error-in-configure.patch;patch=1 \
     file://no-strip.patch;patch=1"
 
 S = "${WORKDIR}/qemu-${PV}"
@@ -45,5 +44,5 @@ EXTRA_OECONF += "--disable-gfx-check"
 inherit autotools
 
 do_configure() {
-    oe_runconf
+    ${S}/configure --prefix=${prefix} ${EXTRA_OECONF}
 }