]> code.ossystems Code Review - openembedded-core.git/commitdiff
poky-image: Set LICENSE field for the image recipes (note this doesn't apply to the...
authorRichard Purdie <rpurdie@linux.intel.com>
Tue, 7 Sep 2010 17:03:51 +0000 (18:03 +0100)
committerRichard Purdie <rpurdie@linux.intel.com>
Tue, 7 Sep 2010 17:03:51 +0000 (18:03 +0100)
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
meta/packages/images/poky-image-clutter.bb
meta/packages/images/poky-image-core.bb
meta/recipes-core/images/poky-image-base.bb
meta/recipes-core/images/poky-image-minimal-directdisk.bb
meta/recipes-core/images/poky-image-minimal-initramfs.bb
meta/recipes-core/images/poky-image-minimal-live.bb
meta/recipes-core/images/poky-image-minimal.bb

index a9bf331f778f35586ced51835d02b9d2dd0a5ac1..a1dcb51b5b742fad9e6b3b7c3746510214ee8fd5 100644 (file)
@@ -1,5 +1,7 @@
 IMAGE_FEATURES += "apps-console-core ${SATO_IMAGE_FEATURES}"
 
+LICENSE = "MIT"
+
 IMAGE_INSTALL = "\
     ${POKY_BASE_INSTALL} \
     task-poky-clutter-core \
index edc50fa74b8e9871825891014f65c5f29fb58395..c232ccdc549ab6cdc69d1fc6f2282f831f28ffd6 100644 (file)
@@ -4,4 +4,6 @@
 
 IMAGE_FEATURES += "apps-console-core ${X11_IMAGE_FEATURES}"
 
+LICENSE = "MIT"
+
 inherit poky-image
index d214642c40cf6bf74aeb4157215d750edde30d97..461b805b60c4cf885a60a40d1710def665d3219c 100644 (file)
@@ -4,4 +4,6 @@
 
 IMAGE_FEATURES += "apps-console-core"
 
+LICENSE = "MIT"
+
 inherit poky-image
index e068464607d861f83fdd8e54dd8c53c60b0afef5..18d993e5427e6ffc4f1f4980a9cda2eace03525e 100644 (file)
@@ -4,6 +4,8 @@ DESCRIPTION = "Minimal Bootable Direct Disk Image"
 
 ROOTFS = "${DEPLOY_DIR_IMAGE}/poky-image-minimal-${MACHINE}.ext3"
 
+LICENSE = "MIT"
+
 do_bootdirectdisk[depends] += "poky-image-minimal:do_rootfs"
 
 
index ef7784b626a7a2e231406f1ee90dc423be53c41c..a94e71218f6cf99dd6de6c8d55d1953cebd3651c 100644 (file)
@@ -5,4 +5,6 @@ IMAGE_INSTALL = "initramfs-live-boot initramfs-live-install busybox udev base-pa
 export IMAGE_BASENAME = "poky-image-minimal-initramfs"
 IMAGE_LINGUAS = ""
 
+LICENSE = "MIT"
+
 inherit poky-image
index 7d9aa5f154a68846e7ab02e6e2718e6a10f4b578..f3d3638ee66ff2f0f5b2eac6836376a2a4b7a3b1 100644 (file)
@@ -6,4 +6,6 @@ LABELS += "boot install"
 
 ROOTFS = "${DEPLOY_DIR_IMAGE}/poky-image-minimal-${MACHINE}.ext3"
 
+LICENSE = "MIT"
+
 do_bootimg[depends] += "poky-image-minimal:do_rootfs"
index 44710a4ca8bc32a18fc708cd7e6b5395216c5c6d..48136ed0f1e37dfae7b4a10bb871eae386ea98bf 100644 (file)
@@ -5,6 +5,8 @@ IMAGE_INSTALL = "task-poky-boot ${ROOTFS_PKGMANAGE}"
 
 IMAGE_LINGUAS = " "
 
+LICENSE = "MIT"
+
 inherit poky-image
 
 # remove not needed ipkg informations