]> code.ossystems Code Review - openembedded-core.git/commitdiff
boost: update to 1.68.0
authorAlexander Kanavin <alex.kanavin@gmail.com>
Thu, 6 Sep 2018 10:29:22 +0000 (12:29 +0200)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 6 Sep 2018 22:43:34 +0000 (23:43 +0100)
Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-support/boost/bjam-native_1.68.0.bb [moved from meta/recipes-support/boost/bjam-native_1.67.0.bb with 100% similarity]
meta/recipes-support/boost/boost-1.68.0.inc [moved from meta/recipes-support/boost/boost-1.67.0.inc with 85% similarity]
meta/recipes-support/boost/boost/0001-Removed-clang-specific-branch-for-x86-DCAS-based-loa.patch [deleted file]
meta/recipes-support/boost/boost_1.68.0.bb [moved from meta/recipes-support/boost/boost_1.67.0.bb with 84% similarity]

similarity index 85%
rename from meta/recipes-support/boost/boost-1.67.0.inc
rename to meta/recipes-support/boost/boost-1.68.0.inc
index 1c7f94022dbf3f00d93a1d45b255222dd7b0ddfc..b367a80b6471cd255bdd3a5644ce1f0f89cf29be 100644 (file)
@@ -12,8 +12,8 @@ BOOST_MAJ = "${@"_".join(d.getVar("PV").split(".")[0:2])}"
 BOOST_P = "boost_${BOOST_VER}"
 
 SRC_URI = "${SOURCEFORGE_MIRROR}/project/boost/boost/${PV}/${BOOST_P}.tar.bz2"
-SRC_URI[md5sum] = "ced776cb19428ab8488774e1415535ab"
-SRC_URI[sha256sum] = "2684c972994ee57fc5632e03bf044746f6eb45d4920c343937a465fd67a5adba"
+SRC_URI[md5sum] = "7fbd1890f571051f2a209681d57d486a"
+SRC_URI[sha256sum] = "7f6130bc3cf65f56a618888ce9d5ea704fa10b462be126ad053e80e553d6d8b7"
 
 UPSTREAM_CHECK_URI = "http://www.boost.org/users/download/"
 UPSTREAM_CHECK_REGEX = "boostorg/release/(?P<pver>.*)/source/"
diff --git a/meta/recipes-support/boost/boost/0001-Removed-clang-specific-branch-for-x86-DCAS-based-loa.patch b/meta/recipes-support/boost/boost/0001-Removed-clang-specific-branch-for-x86-DCAS-based-loa.patch
deleted file mode 100644 (file)
index 1826930..0000000
+++ /dev/null
@@ -1,76 +0,0 @@
-From 39b027171e0a619d49b9dd2e8471d10b6c41bc25 Mon Sep 17 00:00:00 2001
-From: Andrey Semashev <andrey.semashev@gmail.com>
-Date: Tue, 17 Jul 2018 12:37:29 +0300
-Subject: [PATCH] Removed clang-specific branch for x86 DCAS-based loads.
-
-The storage to load from is const-qualified and DCAS via compiler intrinsics
-require an unqualified pointer. Use asm implementation instead, which should be
-as efficient as intrinsics, if not better, in this case.
-
-Fixes https://github.com/boostorg/atomic/issues/15.
-
-Upstream-Status: Backport [https://github.com/boostorg/atomic/commit/6e14ca24dab50ad4c1fa8c27c7dd6f1cb791b534]
-Signed-off-by: Khem Raj <raj.khem@gmail.com>
----
- boost/atomic/detail/ops_gcc_x86_dcas.hpp | 23 ++++++++++++-----------
- 1 file changed, 12 insertions(+), 11 deletions(-)
-
-diff --git a/boost/atomic/detail/ops_gcc_x86_dcas.hpp b/boost/atomic/detail/ops_gcc_x86_dcas.hpp
-index 4dacc66f..b43ef23a 100644
---- a/boost/atomic/detail/ops_gcc_x86_dcas.hpp
-+++ b/boost/atomic/detail/ops_gcc_x86_dcas.hpp
-@@ -158,11 +158,13 @@ struct gcc_dcas_x86
-         }
-         else
-         {
--#if defined(__clang__)
--            // Clang cannot allocate eax:edx register pairs but it has sync intrinsics
--            value = __sync_val_compare_and_swap(&storage, (storage_type)0, (storage_type)0);
--#elif defined(BOOST_ATOMIC_DETAIL_X86_NO_ASM_AX_DX_PAIRS)
-+            // Note that despite const qualification cmpxchg8b below may issue a store to the storage. The storage value
-+            // will not change, but this prevents the storage to reside in read-only memory.
-+
-+#if defined(BOOST_ATOMIC_DETAIL_X86_NO_ASM_AX_DX_PAIRS)
-+
-             uint32_t value_bits[2];
-+
-             // We don't care for comparison result here; the previous value will be stored into value anyway.
-             // Also we don't care for ebx and ecx values, they just have to be equal to eax and edx before cmpxchg8b.
-             __asm__ __volatile__
-@@ -175,7 +177,9 @@ struct gcc_dcas_x86
-                 : BOOST_ATOMIC_DETAIL_ASM_CLOBBER_CC_COMMA "memory"
-             );
-             BOOST_ATOMIC_DETAIL_MEMCPY(&value, value_bits, sizeof(value));
-+
- #else // defined(BOOST_ATOMIC_DETAIL_X86_NO_ASM_AX_DX_PAIRS)
-+
-             // We don't care for comparison result here; the previous value will be stored into value anyway.
-             // Also we don't care for ebx and ecx values, they just have to be equal to eax and edx before cmpxchg8b.
-             __asm__ __volatile__
-@@ -187,6 +191,7 @@ struct gcc_dcas_x86
-                 : [storage] "m" (storage)
-                 : BOOST_ATOMIC_DETAIL_ASM_CLOBBER_CC_COMMA "memory"
-             );
-+
- #endif // defined(BOOST_ATOMIC_DETAIL_X86_NO_ASM_AX_DX_PAIRS)
-         }
-@@ -401,15 +406,11 @@ struct gcc_dcas_x86_64
-     static BOOST_FORCEINLINE storage_type load(storage_type const volatile& storage, memory_order) BOOST_NOEXCEPT
-     {
--#if defined(__clang__)
-+        // Note that despite const qualification cmpxchg16b below may issue a store to the storage. The storage value
-+        // will not change, but this prevents the storage to reside in read-only memory.
--        // Clang cannot allocate rax:rdx register pairs but it has sync intrinsics
--        storage_type value = storage_type();
--        return __sync_val_compare_and_swap(&storage, value, value);
--
--#elif defined(BOOST_ATOMIC_DETAIL_X86_NO_ASM_AX_DX_PAIRS)
-+#if defined(BOOST_ATOMIC_DETAIL_X86_NO_ASM_AX_DX_PAIRS)
--        // Some compilers can't allocate rax:rdx register pair either and also don't support 128-bit __sync_val_compare_and_swap
-         uint64_t value_bits[2];
-         // We don't care for comparison result here; the previous value will be stored into value anyway.
similarity index 84%
rename from meta/recipes-support/boost/boost_1.67.0.bb
rename to meta/recipes-support/boost/boost_1.68.0.bb
index ef178edc0cca7e01795d5ccf449178dd20be0d08..c7958a4c5ed146d534915ea59b6d6d011ae919db 100644 (file)
@@ -8,5 +8,4 @@ SRC_URI += "\
            file://0001-Apply-boost-1.62.0-no-forced-flags.patch.patch \
            file://0003-Don-t-set-up-arch-instruction-set-flags-we-do-that-o.patch \
            file://0001-make_x86_64_sysv_elf_gas.S-set-.file-section.patch \
-           file://0001-Removed-clang-specific-branch-for-x86-DCAS-based-loa.patch \
            "