]> code.ossystems Code Review - openembedded-core.git/commitdiff
pseudo_1.7.4.bb: fix f*open()
authorPeter Seebach <peter.seebach@windriver.com>
Tue, 22 Sep 2015 22:59:10 +0000 (17:59 -0500)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 23 Sep 2015 10:14:28 +0000 (11:14 +0100)
The 0600 modes were coming from fopen/freopen/etc., because those
don't specify a filesystem mode (just an access mode like "r" or
"w"). Use 0666 & ~umask. (And then the PSEUDO_FS_MODE macro masks
in the 0600 bits we want to be sure are present.)

Signed-off-by: Peter Seebach <peter.seebach@windriver.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-devtools/pseudo/pseudo_1.7.4.bb [moved from meta/recipes-devtools/pseudo/pseudo_1.7.3.bb with 77% similarity]
meta/recipes-devtools/pseudo/pseudo_git.bb

similarity index 77%
rename from meta/recipes-devtools/pseudo/pseudo_1.7.3.bb
rename to meta/recipes-devtools/pseudo/pseudo_1.7.4.bb
index 1e9ef3bb98ed8d85180c9d45a9100167b88a37f6..d68e0af7d53b6f1c6bbc902eedb610b672ecd2cf 100644 (file)
@@ -6,8 +6,8 @@ SRC_URI = " \
     file://fallback-group \
 "
 
-SRC_URI[md5sum] = "2bd0a44eadd4713e90ad8c152eea77aa"
-SRC_URI[sha256sum] = "e9fc3922f8feb97839b50d14eb1987afdc8f22cdcac93119323cccd5f8444652"
+SRC_URI[md5sum] = "6e4b59a346d08d4a29133c335ea12052"
+SRC_URI[sha256sum] = "f33ff84da328f943155f22cfd49030ef4ad85ad35fc2d9419a203521b65c384c"
 
 PSEUDO_EXTRA_OPTS ?= "--enable-force-async --without-passwd-fallback"
 
index 31e1223a48f63919269f73de56e7bfceef254ce4..eb666c064d993c5e0ec5b909cd091c8364027ac5 100644 (file)
@@ -1,7 +1,7 @@
 require pseudo.inc
 
-SRCREV = "e795df44a90a426a76b790f1b2774f3046a8fc31"
-PV = "1.7.2+git${SRCPV}"
+SRCREV = "3bc3909fa70535c2ef876009dc58e577b10a7e0e"
+PV = "1.7.4+git${SRCPV}"
 
 DEFAULT_PREFERENCE = "-1"