]> code.ossystems Code Review - openembedded-core.git/commitdiff
iputils: enable generation of man pages
authorScott Garman <scott.a.garman@intel.com>
Wed, 16 Feb 2011 00:39:31 +0000 (16:39 -0800)
committerSaul Wold <sgw@linux.intel.com>
Wed, 16 Feb 2011 15:45:19 +0000 (07:45 -0800)
This fixes [BUGID #211]

Signed-off-by: Scott Garman <scott.a.garman@intel.com>
meta/recipes-extended/iputils/iputils_s20101006.bb

index 0a4201787ce269bfa8dfe93c53c3c693e52fb5e9..c4db5b47469d5b1bb0a12810b5934647b740e2fb 100644 (file)
@@ -11,7 +11,7 @@ LIC_FILES_CHKSUM = "file://ping.c;beginline=1;endline=35;md5=f9ceb201733e9a6cf8f
                     file://arping.c;beginline=1;endline=10;md5=ada2a6d06acc90f943bddf40d15e0541 \
                     file://tftpd.c;beginline=1;endline=32;md5=28834bf8a91a5b8a92755dbee709ef96 "
 
-DEPENDS = "sysfsutils openssl"
+DEPENDS = "sysfsutils openssl docbook-utils-native"
 
 PR = "r0"
 
@@ -26,11 +26,8 @@ SRC_URI = "http://www.skbuff.net/iputils/${PN}-${PV}.tar.bz2 \
 SRC_URI[md5sum] = "a36c25e9ec17e48be514dc0485e7376c"
 SRC_URI[sha256sum] = "fd3af46c80ebb99607c2ca1f2a3608b6fe828e25bbec6e54f2afd25f6ddb6ee7"
 
-# man is not compiled here, since it requires docbook-utils-native
-# which is not available in poky
-
 do_compile () {
-       oe_runmake 'CC=${CC} -D_GNU_SOURCE' VPATH="${STAGING_LIBDIR}" all
+       oe_runmake 'CC=${CC} -D_GNU_SOURCE' VPATH="${STAGING_LIBDIR}" all man
 }
 
 do_install () {
@@ -44,9 +41,9 @@ do_install () {
          install -m 0755 $i ${D}${base_bindir}/
        done
        # Manual pages for things we build packages for
-#      for i in tracepath.8 traceroute6.8 ping.8 arping.8; do
-#        install -m 0644 doc/$i ${D}${mandir}/man8/ || true
-#      done
+       for i in tracepath.8 traceroute6.8 ping.8 arping.8; do
+         install -m 0644 doc/$i ${D}${mandir}/man8/ || true
+       done
 }
 
 # Busybox also provides ping and ping6, so use update-alternatives