]> code.ossystems Code Review - openembedded-core.git/commitdiff
Change db to 4.1.25, update PR's across the board
authorRichard Purdie <richard@openedhand.com>
Fri, 30 Sep 2005 17:25:47 +0000 (17:25 +0000)
committerRichard Purdie <richard@openedhand.com>
Fri, 30 Sep 2005 17:25:47 +0000 (17:25 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky@89 311d38ba-8fff-0310-9ca6-ca027cbcb966

openembedded/packages/contacts/contacts_0.0.bb
openembedded/packages/dates/dates_svn.bb
openembedded/packages/db/db_4.1.25.bb [moved from openembedded/packages/db/db_4.3.27.bb with 91% similarity]
openembedded/packages/eds/eds-dbus/external_libdb.patch
openembedded/packages/eds/eds-dbus_svn.bb
openembedded/packages/meta/meta-oh.bb
openembedded/packages/meta/oh-image.bb

index c855997343e7bd936fc206a23b4046f4e0d0aa8e..02a8903206226aa74ba94bcd8686bbcce24b07ba 100755 (executable)
@@ -3,6 +3,8 @@ SECTION = "x11"
 DEPENDS = "glib-2.0 gtk+ libglade eds-dbus"
 MAINTAINER = "Chris Lord <chris@openedhand.com>"
 DESCRIPTION = "Contacts is an address-book application."
+PR = "r1"
+
 
 SRC_URI = "file:///tmp/${PN}-${PV}.tar.gz"
 
index be8e40d3681d38ee48a27b639aa436acd36a52c2..eea555c9499f9be780245c2b2bf10a8b7594d67f 100755 (executable)
@@ -4,6 +4,8 @@ DEPENDS = "glib-2.0 gtk+ libglade eds-dbus"
 MAINTAINER = "Chris Lord <chris@openedhand.com>"
 DESCRIPTION = "Dates is a calendar application."
 
+PR = "r1"
+
 PV = "0.0cvs${CVSDATE}"
 S = "${WORKDIR}/${PN}"
 
similarity index 91%
rename from openembedded/packages/db/db_4.3.27.bb
rename to openembedded/packages/db/db_4.1.25.bb
index 518fddee9fa6d1bd5a3a9be71a7b2c83b957e283..168dde478d8180d1359167fd78f96838af393b10 100644 (file)
@@ -73,17 +73,20 @@ do_stage() {
        # Install, for the moment, into include/db4 to avoid
        # interfering with the db3 headers (which have the same
        # name).  -I${STAGING_INCDIR}/db4 to use db4, as opposed
-       # to db3.
+       # to db3
+       
        rm -rf ${STAGE_TEMP}
        mkdir -p ${STAGE_TEMP}
-       oe_runmake DESTDIR="${STAGE_TEMP}" install_include
+       oe_runmake DESTDIR="${STAGE_TEMP}" includedir="${STAGE_TEMP}${includedir}" install_include
        mkdir -p ${STAGING_INCDIR}/db4
        cp -pPRf ${STAGE_TEMP}/${includedir}/* ${STAGING_INCDIR}/db4
        rm -rf ${STAGE_TEMP}
-       oe_libinstall -so -C .libs libdb-4.3 ${STAGING_LIBDIR}
+       oe_libinstall -so -C .libs libdb-4.1 ${STAGING_LIBDIR}
 }
 
-do_install_append() {
+do_install() {
+       oe_runmake includedir="${D}${includedir}" libdir="${D}${libdir}" bindir="${D}${bindir}" docdir="${D}${docdir}" install
+
        # The docs end up in /usr/docs - not right.
        if test -d "${D}/${prefix}/docs"
        then
index ebb32403e87719335f61adfe154175788763d8ca..50b9e9b48a5441ac29a573cacb1f8f517f6b8b2b 100644 (file)
@@ -36,14 +36,14 @@ Index: trunk/configure.in
  AC_SUBST(REGEX_LIBS)
  
  dnl ******************************
-+dnl * db-4.3 checking
++dnl * db-4.1 checking
 +dnl ******************************
 +
-+AC_ARG_WITH(libdb43, [  --with-libdb43         Prefix where libdb 4.3 is installed])
++AC_ARG_WITH(libdb41, [  --with-libdb41         Prefix where libdb 4.1 is installed])
 +case $withval in
 +/*)
 +    DB_CFLAGS="-I$withval/include/db4"
-+    DB_LIBS="-L$withval/lib -ldb-4.3"
++    DB_LIBS="-L$withval/lib -ldb-4.1"
 +    ;;
 +esac
 +
index 2ffa363fe224549606adc219b3df4e0d30f5b518..77ea4141da44c018441d17b54da52af3809d0a6c 100755 (executable)
@@ -4,7 +4,7 @@ RDEPENDS = "gtk+ gconf db libiconv"
 MAINTAINER = "Chris Lord <chris@openedhand.com>"
 DESCRIPTION = "Evolution database backend server"
 PV = "1.4.0cvs${CVSDATE}"
-PR = "r4"
+PR = "r5"
 
 SRC_URI = "svn://svn.o-hand.com/repos/${PN};module=trunk;proto=http \
            file://external_libdb.patch;patch=1 \
@@ -17,7 +17,7 @@ S = "${WORKDIR}/trunk"
 
 inherit autotools pkgconfig
 
-EXTRA_OECONF = "--without-openldap --disable-nntp --disable-gtk-doc --with-dbus=yes --with-libgnome=no --enable-soup=no --with-libdb43=${STAGING_DIR}/${HOST_SYS} --enable-smime=no --enable-nss=no --disable-camel"
+EXTRA_OECONF = "--without-openldap --disable-nntp --disable-gtk-doc --with-dbus=yes --with-libgnome=no --enable-soup=no --with-libdb41=${STAGING_DIR}/${HOST_SYS} --enable-smime=no --enable-nss=no --disable-camel"
 
 acpaths = " -I ${STAGING_DATADIR}/aclocal/gnome-macros "
 
index 7a82a69e30caa6ae2a6a305549d1610e7fb61463..c2d3110af663456b04397e2deb7e04fa6566408b 100644 (file)
@@ -2,7 +2,7 @@ PACKAGES = "oh-base-depends oh-task-base"
 # oh-task-base
 DESCRIPTION = "Meta-package for OpenHand Palmtop Environment"
 MAINTAINER = "Richard Purdie <richard@openedhand.com>"
-PR = "r11"
+PR = "r14"
 
 ALLOW_EMPTY = "1"
 
index 20dd7a6096192dc4b7a19d6155ecd1d5b082f363..c4a0f84571bdf8f619a7b7a8937b15e774f43b17 100644 (file)
@@ -1,4 +1,4 @@
-PR = "r6"
+PR = "r8"
 
 export IMAGE_BASENAME = "oh-image"