]> code.ossystems Code Review - openembedded-core.git/commitdiff
build-appliance-image: Install network components
authorJuro Bystricky <juro.bystricky@intel.com>
Thu, 16 Jun 2016 20:32:23 +0000 (13:32 -0700)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 16 Jun 2016 21:43:17 +0000 (22:43 +0100)
Explicitly add network components into Build Appliance image,
do not rely on packagegroup-self-hosted to pull them in.
Network related dependencies were removed from packagegroup-self-hosted.

YOCTO #9758

Signed-off-by: Juro Bystricky <juro.bystricky@intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-core/images/build-appliance-image_15.0.0.bb

index 9dbfd1b93e4a67807d3ae7429a69e8a2451fc557..d8d70482ea9605185ba87d32c18c3dadc30f94db 100644 (file)
@@ -6,7 +6,8 @@ LICENSE = "MIT"
 LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=4d92cd373abda3937c2bc47fbc49d690 \
                     file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
 
-IMAGE_INSTALL = "packagegroup-core-boot packagegroup-core-ssh-openssh packagegroup-self-hosted kernel-dev kernel-devsrc "
+IMAGE_INSTALL = "packagegroup-core-boot packagegroup-core-ssh-openssh packagegroup-self-hosted \
+                 kernel-dev kernel-devsrc connman connman-plugin-ethernet dhcp-client"
 
 IMAGE_FEATURES += "x11-base package-management splash"