]> code.ossystems Code Review - openembedded-core.git/commitdiff
Drop unneeded LIC_FILES_CHKSUM values
authorPaul Eggleton <paul.eggleton@linux.intel.com>
Mon, 9 May 2016 22:25:06 +0000 (10:25 +1200)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 11 May 2016 09:08:31 +0000 (10:08 +0100)
With the changes to insane.bbclass we don't need LIC_FILES_CHKSUM to be
set for recipes that don't actually pull in any source.

Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta-selftest/recipes-test/images/test-empty-image.bb
meta/classes/core-image.bbclass
meta/classes/packagegroup.bbclass
meta/recipes-core/meta/meta-world-pkgdata.bb
meta/recipes-graphics/images/core-image-directfb.bb

index 7847f83b4b48748e5a52bee8f64c432e2328cbad..88d8d612e8e281c3bd61e30807f4d025beb1a75a 100644 (file)
@@ -2,6 +2,5 @@ SUMMARY = "An empty image."
 IMAGE_INSTALL = ""
 IMAGE_LINGUAS = ""
 PACKAGE_INSTALL = ""
-LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
 
 inherit image
index 705cad8d914a9ab7557bb57052e1df5af631652c..8431440db420438357da11fc836b7c3f8b86f1d9 100644 (file)
@@ -2,9 +2,6 @@
 #
 # Copyright (C) 2007-2011 Linux Foundation
 
-LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=4d92cd373abda3937c2bc47fbc49d690 \
-                    file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
-
 # IMAGE_FEATURES control content of the core reference images
 # 
 # By default we install packagegroup-core-boot and packagegroup-base-extended packages;
index 3674894e7f1c1069d20fa97444993edde64bc6c3..3928c8a4ac7ce92169730b0649a3e0bbf19cd727 100644 (file)
@@ -15,9 +15,6 @@ PACKAGE_ARCH ?= "all"
 PACKAGE_ARCH_EXPANDED := "${PACKAGE_ARCH}"
 
 LICENSE ?= "MIT"
-LIC_FILES_CHKSUM ?= "${@oe.utils.ifelse(d.getVar('LICENSE', True) == 'MIT', \
-                     'file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420', \
-                    '')}"
 
 inherit ${@oe.utils.ifelse(d.getVar('PACKAGE_ARCH_EXPANDED', True) == 'all', 'allarch', '')}
 
index b3989cd81e6f7783bfc57e11b2438797304a9fce..81c8647fa6464a5a50a80a43dc931eb8dbb79b26 100644 (file)
@@ -1,6 +1,5 @@
 SUMMARY = "Pulls in pkgdata for world"
 LICENSE = "MIT"
-LIC_FILES_CHKSUM ?= "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
 
 INHIBIT_DEFAULT_DEPS = "1"
 
index 5641195e8c20c06dec123f03d87a5f8c096aa807..c6ce658d61ff68682ee017bc8e127f41d310d677 100644 (file)
@@ -1,10 +1,6 @@
 SUMMARY = "An image that uses DirectFB instead of X11"
 LICENSE = "MIT"
 
-
-LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=4d92cd373abda3937c2bc47fbc49d690 \
-                    file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
-
 inherit core-image distro_features_check
 
 REQUIRED_DISTRO_FEATURES = "directfb"