]> code.ossystems Code Review - openembedded-core.git/commitdiff
distutils.bbclass: fix libdir for 64-bit python modules built with distutils
authorMatthew McClintock <msm@freescale.com>
Mon, 13 Aug 2012 19:44:31 +0000 (14:44 -0500)
committerScott Garman <scott.a.garman@intel.com>
Mon, 24 Sep 2012 16:51:09 +0000 (09:51 -0700)
Without this some modules will be intalled in /usr/lib/python2.6/
instead of /usr/${libdir}/python2.6

(From OE-Core rev: bc6bd774aa8a3e085e9cabcefb11c3fc537139d5)

Signed-off-by: Matthew McClintock <msm@freescale.com>
Signed-off-by: Saul Wold <sgw@linux.intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/classes/distutils.bbclass

index 18ae805f7bbce846c98e0297d4cbe67102a626a2..67ad5b3416d3de6425b722a2986f3f081590481a 100644 (file)
@@ -38,7 +38,7 @@ distutils_do_install() {
         STAGING_LIBDIR=${STAGING_LIBDIR} \
         PYTHONPATH=${D}/${PYTHON_SITEPACKAGES_DIR} \
         BUILD_SYS=${BUILD_SYS} HOST_SYS=${HOST_SYS} \
-        ${STAGING_BINDIR_NATIVE}/python setup.py install ${DISTUTILS_INSTALL_ARGS} || \
+        ${STAGING_BINDIR_NATIVE}/python setup.py install ${DISTUTILS_INSTALL_ARGS} --install-lib=${D}${libdir}/${PYTHON_DIR} || \
         bbfatal "python setup.py install execution failed."
 
         for i in `find ${D} -name "*.py"` ; do \