]> code.ossystems Code Review - openembedded-core.git/commitdiff
wic-tools: Do not remove sysroot with rm_work, because wic needs it.
authorKristian Amlie <kristian.amlie@mender.io>
Mon, 30 Jan 2017 15:43:38 +0000 (16:43 +0100)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 2 Feb 2017 17:37:33 +0000 (17:37 +0000)
The sysroot of wic-tools is needed for wic, but if rm_work is enabled,
it will be removed before wic has a chance to use it, hence this fix.

Signed-off-by: Kristian Amlie <kristian.amlie@mender.io>
Signed-off-by: Ross Burton <ross.burton@intel.com>
meta/recipes-core/meta/wic-tools.bb

index 1d9ea9c0e952c9d853ea63810447981270d09cdb..bd4319a8039ed00778163a0fa20917e2a5cd2bc3 100644 (file)
@@ -9,6 +9,10 @@ DEPENDS_append_x86-64 = " syslinux grub-efi systemd-boot"
 INHIBIT_DEFAULT_DEPS = "1"
 inherit nopackages
 
+# The sysroot of wic-tools is needed for wic, but if rm_work is enabled, it will
+# be removed before wic has a chance to use it, hence the exclusion below.
+RM_WORK_EXCLUDE += "${PN}"
+
 python do_build_sysroot () {
     bb.build.exec_func("extend_recipe_sysroot", d)