]> code.ossystems Code Review - openembedded-core.git/commitdiff
oprofile: fix arithmetic ops on dash
authorRoss Burton <ross@openedhand.com>
Tue, 27 Nov 2007 16:30:56 +0000 (16:30 +0000)
committerRoss Burton <ross@openedhand.com>
Tue, 27 Nov 2007 16:30:56 +0000 (16:30 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@3259 311d38ba-8fff-0310-9ca6-ca027cbcb966

meta/packages/oprofile/oprofile/fix-arith.patch [new file with mode: 0644]
meta/packages/oprofile/oprofile_0.9.3.bb

diff --git a/meta/packages/oprofile/oprofile/fix-arith.patch b/meta/packages/oprofile/oprofile/fix-arith.patch
new file mode 100644 (file)
index 0000000..5c55f4b
--- /dev/null
@@ -0,0 +1,52 @@
+Index: utils/opcontrol
+===================================================================
+RCS file: /cvsroot/oprofile/oprofile/utils/opcontrol,v
+retrieving revision 1.148
+diff -u -r1.148 opcontrol
+--- utils/opcontrol    8 Nov 2007 09:24:30 -0000       1.148
++++ utils/opcontrol    27 Nov 2007 17:02:20 -0000
+@@ -395,7 +395,7 @@
+       echo "SESSION_DIR=$SESSION_DIR" >>$SETUP_FILE
+       if test "$NR_CHOSEN" != "0"; then
+-              for f in `seq 0 $((NR_CHOSEN - 1))`; do
++              for f in `seq 0 $(($NR_CHOSEN - 1))`; do
+                       get_event $f
+                       echo "CHOSEN_EVENTS_${f}=$GOTEVENT" >>$SETUP_FILE
+               done
+@@ -590,7 +590,7 @@
+       OPHELP_ARGS=
+       if test "$NR_CHOSEN" != 0; then
+-              for f in `seq 0 $((NR_CHOSEN - 1))`; do
++              for f in `seq 0 $(($NR_CHOSEN - 1))`; do
+                       get_event $f
+                       if test "$GOTEVENT" != ""; then
+                               OPHELP_ARGS="$OPHELP_ARGS $GOTEVENT"
+@@ -612,7 +612,7 @@
+               return
+       fi
+-      for f in `seq 0 $((NR_CHOSEN - 1))`; do
++      for f in `seq 0 $(($NR_CHOSEN - 1))`; do
+               get_event $f
+               if test "$GOTEVENT" != ""; then
+                       EVENT=`echo $GOTEVENT | awk -F: '{print $1}'`
+@@ -1226,7 +1226,7 @@
+       verify_counters
+       OPROFILED_EVENTS=
+-      for f in `seq 0 $((NR_CHOSEN - 1))`; do
++      for f in `seq 0 $(($NR_CHOSEN - 1))`; do
+               get_event $f
+               if test "$GOTEVENT" != ""; then
+                       EVENT=`echo $GOTEVENT | awk -F: '{print $1}'`
+@@ -1383,7 +1383,7 @@
+       fi
+       if test "$NR_CHOSEN" != "0"; then
+-              for f in `seq 0 $((NR_CHOSEN - 1))`; do
++              for f in `seq 0 $(($NR_CHOSEN - 1))`; do
+                       get_event $f
+                       echo "Event $f: $GOTEVENT"
+               done
index c4ea585c85a6a5f64ff801899bd6365ecdb923e8..c4194ab2e12973b401bd105f2f5fd79e85a38ace 100644 (file)
@@ -4,13 +4,14 @@ of profiling all running code at low overhead."
 LICENSE = "GPL"
 DEPENDS = "popt binutils"
 RDEPENDS = "binutils-symlinks"
-PR = "r3"
+PR = "r4"
 
 SRC_URI = "${SOURCEFORGE_MIRROR}/oprofile/oprofile-${PV}.tar.gz \
            file://armv6_fix.patch;patch=1 \
            file://oparchive_fix.patch;patch=1 \
            file://root_option.patch;patch=1 \
            file://opstart.patch;patch=1 \
+           file://fix-arith.patch;patch=1;pnum=0 \
            file://acinclude.m4"
 S = "${WORKDIR}/oprofile-${PV}"