]> code.ossystems Code Review - openembedded-core.git/commitdiff
libpng12: rename libpng_1.2.50 to libpng12
authorKang Kai <kai.kang@windriver.com>
Tue, 9 Apr 2013 03:16:37 +0000 (11:16 +0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 9 Apr 2013 12:09:47 +0000 (13:09 +0100)
As Mark's suggestion, rename libpng_1.2.50 to libpng12 that
multi-versions libpng could coexist.

We want to make sure we have both the old and new versions to meet LSB
compliance (for people who have that enabled) as well as the new version
for newer applications.

And drop link files that conflict with higher version.

[YOCTO #4221]

Signed-off-by: Kang Kai <kai.kang@windriver.com>
CC: Mark Hatle <mark.hatle@windriver.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-lsb4/libpng/libpng12_1.2.50.bb [moved from meta/recipes-lsb4/libpng/libpng_1.2.50.bb with 55% similarity]

similarity index 55%
rename from meta/recipes-lsb4/libpng/libpng_1.2.50.bb
rename to meta/recipes-lsb4/libpng/libpng12_1.2.50.bb
index 8fdc41ba1929e6565a85fd2e807b88bf6205ef78..cfefd41beb6b202ab9cc8e8456c5c7f1d7c6911a 100644 (file)
@@ -8,14 +8,28 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=c3d807a85c09ebdff087f18b4969ff96 \
 DEPENDS = "zlib"
 PR = "r0"
 
+PN = "libpng12"
+S = "${WORKDIR}/libpng-${PV}"
+
 SRC_URI = "${SOURCEFORGE_MIRROR}/project/libpng/libpng12/${PV}/libpng-${PV}.tar.xz"
 
 SRC_URI[md5sum] = "a3e00fccbfe356174ab515b5c00641c7"
 SRC_URI[sha256sum] = "4724f81f8c92ac7f360ad1fbf173396ea7c535923424db9fbaff07bfd9d8e8e7"
 
+BINCONFIG_GLOB = "${PN}-config"
+
 inherit autotools binconfig pkgconfig
 
-PACKAGES =+ "${PN}12"
+do_install_append() {
+       # The follow link files link to corresponding png12*.h and libpng12* files
+       # They conflict with higher verison, so drop them
+       unlink ${D}/${includedir}/png.h
+       unlink ${D}/${includedir}/pngconf.h
+
+       unlink ${D}/${libdir}/libpng.la
+       unlink ${D}/${libdir}/libpng.so
+       unlink ${D}/${libdir}/libpng.a
+       unlink ${D}/${libdir}/pkgconfig/libpng.pc
 
-FILES_${PN}12 = "${libdir}/libpng12${SOLIBS}"
-RPROVIDES_${PN}-dev += "${PN}12-dev"
+       unlink ${D}/${bindir}/libpng-config
+}