]> code.ossystems Code Review - openembedded-core.git/commitdiff
linux-yocto/5.10: fix arm defconfig warnings
authorBruce Ashfield <bruce.ashfield@gmail.com>
Tue, 20 Apr 2021 12:31:26 +0000 (08:31 -0400)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 21 Apr 2021 21:43:55 +0000 (22:43 +0100)
A recent fix to the kern-tools promoted some previously unseen
issues to warnings. This commit fixes them by tagging some BT
options as non-hardware so they won't generate warnings if they
don't appear in the final .config. These are sub BT options and
shouldn't warn when/if their controlling option is disabled by
a fragment.

    40a967b115f base: exclude some BT options as non-hardware

Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-kernel/linux/linux-yocto-rt_5.10.bb
meta/recipes-kernel/linux/linux-yocto-tiny_5.10.bb
meta/recipes-kernel/linux/linux-yocto_5.10.bb

index 20faff811a522926847bd0d62bccaf30907b3fdc..dacff74bce46f3c66954b9b900773d4094430e87 100644 (file)
@@ -12,7 +12,7 @@ python () {
 }
 
 SRCREV_machine ?= "ac98a75ef2bc550f67454bd738ede581c8846ff3"
-SRCREV_meta ?= "b7125842b7ce188e7846a49fcb15a71c54806d6c"
+SRCREV_meta ?= "40a967b115fdbac34fc980d0e27ac2373a031189"
 
 SRC_URI = "git://git.yoctoproject.org/linux-yocto.git;branch=${KBRANCH};name=machine \
            git://git.yoctoproject.org/yocto-kernel-cache;type=kmeta;name=meta;branch=yocto-5.10;destsuffix=${KMETA}"
index 54575a7917b9fa9544d0a4c1d1342a473765d119..21a2e89115c35e647521e1151f7f89bf70232603 100644 (file)
@@ -17,7 +17,7 @@ KCONF_BSP_AUDIT_LEVEL = "2"
 
 SRCREV_machine_qemuarm ?= "ee7efde0c94e8b2eba1a5a2709f2d21874ac7525"
 SRCREV_machine ?= "8465e471f5b4855d01012a18cd5fa516061c0358"
-SRCREV_meta ?= "b7125842b7ce188e7846a49fcb15a71c54806d6c"
+SRCREV_meta ?= "40a967b115fdbac34fc980d0e27ac2373a031189"
 
 PV = "${LINUX_VERSION}+git${SRCPV}"
 
index e93e41c69b5ef974a761bf99deafcb90bd03bd2d..e6859a2319ea875700d561b60201316e53c58320 100644 (file)
@@ -17,13 +17,13 @@ SRCREV_machine_qemuarm ?= "4f13e8499f2bfc9d95dcc70b981ea16351ff088b"
 SRCREV_machine_qemuarm64 ?= "8465e471f5b4855d01012a18cd5fa516061c0358"
 SRCREV_machine_qemumips ?= "64f8949180b1a6375abef20eebf735e853701c71"
 SRCREV_machine_qemuppc ?= "8465e471f5b4855d01012a18cd5fa516061c0358"
-SRCREV_machine_qemuriscv64 ?= "8465e471f5b4855d01012a18cd5fa516061c0358"
-SRCREV_machine_qemuriscv32 ?= "8465e471f5b4855d01012a18cd5fa516061c0358"
-SRCREV_machine_qemux86 ?= "8465e471f5b4855d01012a18cd5fa516061c0358"
-SRCREV_machine_qemux86-64 ?= "8465e471f5b4855d01012a18cd5fa516061c0358"
+SRCREV_machine_qemuriscv64 ?= "d6e20b2257ecfa6e796a45a4175863862a28fa11"
+SRCREV_machine_qemuriscv32 ?= "d6e20b2257ecfa6e796a45a4175863862a28fa11"
+SRCREV_machine_qemux86 ?= "d6e20b2257ecfa6e796a45a4175863862a28fa11"
+SRCREV_machine_qemux86-64 ?= "d6e20b2257ecfa6e796a45a4175863862a28fa11"
 SRCREV_machine_qemumips64 ?= "6bf49ed9b223173d918b7c0140b8d0561bc2674c"
-SRCREV_machine ?= "8465e471f5b4855d01012a18cd5fa516061c0358"
-SRCREV_meta ?= "b7125842b7ce188e7846a49fcb15a71c54806d6c"
+SRCREV_machine ?= "d6e20b2257ecfa6e796a45a4175863862a28fa11"
+SRCREV_meta ?= "40a967b115fdbac34fc980d0e27ac2373a031189"
 
 # remap qemuarm to qemuarma15 for the 5.8 kernel
 # KMACHINE_qemuarm ?= "qemuarma15"