]> code.ossystems Code Review - openembedded-core.git/commitdiff
xwayland: port packageconfig from xserver-xorg recipe
authorMax Krummenacher <max.oss.09@gmail.com>
Sat, 26 Jun 2021 09:54:15 +0000 (11:54 +0200)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Sun, 27 Jun 2021 15:03:32 +0000 (16:03 +0100)
Copy the packageconfig options from the xserver-xorg recipe to
allow configuring for non mesa opengl backends.

Keep the defaults as set in the xserver-xorg recipe.

The following options no longer exists and are dropped:
udev dga dri dri2 xshmfence xmlto systemd-logind systemd xwayland

Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-graphics/xwayland/xwayland_21.1.1.bb

index 8b1c96fc4aed8c5e361970326e87f51d1a570f83..faf166f7880801fe964e61e90f752d69728825da 100644 (file)
@@ -17,6 +17,22 @@ REQUIRED_DISTRO_FEATURES = "x11 opengl"
 
 DEPENDS += "xorgproto xtrans pixman libxkbfile libxfont2 wayland wayland-native wayland-protocols libdrm libepoxy"
 
+OPENGL_PKGCONFIGS = "glx glamor dri3"
+PACKAGECONFIG ??= "${XORG_CRYPTO} \
+                   ${@bb.utils.contains('DISTRO_FEATURES', 'opengl', '${OPENGL_PKGCONFIGS}', '', d)} \
+"
+PACKAGECONFIG[dri3] = "-Ddri3=true,-Ddri3=false"
+PACKAGECONFIG[glx] = "-Dglx=true,-Dglx=false,virtual/libgl virtual/libx11"
+PACKAGECONFIG[glamor] = "-Dglamor=true,-Dglamor=false,libepoxy virtual/libgbm,libegl"
+PACKAGECONFIG[unwind] = "-Dlibunwind=true,-Dlibunwind=false,libunwind"
+PACKAGECONFIG[xinerama] = "-Dxinerama=true,-Dxinerama=false"
+
+# Xorg requires a SHA1 implementation, pick one
+XORG_CRYPTO ??= "openssl"
+PACKAGECONFIG[openssl] = "-Dsha1=libcrypto,,openssl"
+PACKAGECONFIG[nettle] = "-Dsha1=libnettle,,nettle"
+PACKAGECONFIG[gcrypt] = "-Dsha1=libgcrypt,,libgcrypt"
+
 do_install_append() {
     # remove files not needed and clashing with xserver-xorg
     rm -rf ${D}/${libdir}/xorg/