]> code.ossystems Code Review - openembedded-core.git/commitdiff
python-pygtk: Fix case where ${B} != ${S}
authorRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 21 Mar 2013 14:22:27 +0000 (14:22 +0000)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 21 Mar 2013 17:04:56 +0000 (17:04 +0000)
Fix out of tree builds by adding missing path component.

Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-devtools/python/python-pygtk_2.24.0.bb

index 624d924f36a7d1571a615cce1cd321d710600917..0342f826c5272514b08c44694a4f80b15fdb9a1a 100644 (file)
@@ -35,7 +35,7 @@ do_configure_prepend() {
                -e s:'`$PKG_CONFIG --variable codegendir pygobject-2.0`':\"${STAGING_DATADIR}/pygobject/2.0/codegen\":g \
                -e s:'`$PKG_CONFIG --variable=fixxref pygobject-2.0`':\"${STAGING_DATADIR}/pygobject/xsl/fixxref.py\":g \
                ${S}/configure.ac
-       sed -i 's:tests docs:tests:' Makefile.am
+       sed -i 's:tests docs:tests:' ${S}/Makefile.am
 }
 
 # dirty fix #1: remove dependency on python-pygobject-dev