]> code.ossystems Code Review - openembedded-core.git/commitdiff
initscripts: avoid mounting /sys if it is already mounted
authorOtavio Salvador <otavio@ossystems.com.br>
Fri, 30 Dec 2011 15:58:47 +0000 (15:58 +0000)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Fri, 6 Jan 2012 11:27:27 +0000 (11:27 +0000)
Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
meta/recipes-core/initscripts/initscripts-1.0/sysfs.sh
meta/recipes-core/initscripts/initscripts_1.0.bb

index be28bb35bfd918b5a222d045ef4aa2a8fd9d1c4f..bd87dcddd24e6a53457c92575a29fd91dc3f8335 100644 (file)
@@ -14,6 +14,6 @@ if [ -e /proc ] && ! [ -e /proc/mounts ]; then
   mount -t proc proc /proc
 fi
 
-if [ -e /sys ] && grep -q sysfs /proc/filesystems; then
-  mount sysfs /sys -t sysfs
+if [ -e /sys ] && grep -q sysfs /proc/filesystems && ! [ -e /sys/class ]; then
+  mount -t sysfs sysfs /sys
 fi
index ffca817cea3349b4bef587f651fad66862a76770..98f5e9bf654ae836abda14a1d9dcadb82adefe38 100644 (file)
@@ -3,7 +3,7 @@ DESCRIPTION = "Initscripts provide the basic system startup initialization scrip
 SECTION = "base"
 LICENSE = "GPLv2"
 LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
-PR = "r127"
+PR = "r128"
 
 INHIBIT_DEFAULT_DEPS = "1"