]> code.ossystems Code Review - openembedded-core.git/commitdiff
libnss-mdns: support ipv6 in lookups
authorKoen Kooi <koen@dominion.thruhere.net>
Tue, 8 Jul 2014 14:35:26 +0000 (16:35 +0200)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Thu, 10 Jul 2014 16:37:40 +0000 (17:37 +0100)
It nothing can resolve the hostname as ipv4 it will also try ipv6.
Ideally the mdns4_minimal should get replaced as well, but there's some
handwaving on the internet stating it will slow things down if your ipv6
network is misconfigured.
Since I can't verify that slowdown I've opted for the safe way and only
do ipv6 lookup in the fallback entry.

Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Signed-off-by: Saul Wold <sgw@linux.intel.com>
meta/recipes-connectivity/libnss-mdns/libnss-mdns_0.10.bb

index 5b8c700411f153dc418149c2784e5e1b58b797b7..df7d196e311ba1cd559a55dd760d8af8f9a422a4 100644 (file)
@@ -26,13 +26,13 @@ DEBIANNAME_${PN} = "libnss-mdns"
 RDEPENDS_${PN} = "avahi-daemon"
 
 pkg_postinst_${PN} () {
-       sed -e '/^hosts:/s/\s*\<mdns4\>//' \
-               -e 's/\(^hosts:.*\)\(\<files\>\)\(.*\)\(\<dns\>\)\(.*\)/\1\2 mdns4_minimal [NOTFOUND=return]\3\4 mdns4\5/' \
+       sed -e '/^hosts:/s/\s*\<mdns\>//' \
+               -e 's/\(^hosts:.*\)\(\<files\>\)\(.*\)\(\<dns\>\)\(.*\)/\1\2 mdns4_minimal [NOTFOUND=return]\3\4 mdns\5/' \
                -i $D/etc/nsswitch.conf
 }
 
 pkg_prerm_${PN} () {
-       sed -e '/^hosts:/s/\s*\<mdns4\>//' \
+       sed -e '/^hosts:/s/\s*\<mdns\>//' \
                -e '/^hosts:/s/\s*mdns4_minimal\s\+\[NOTFOUND=return\]//' \
                -i $D/etc/nsswitch.conf
 }