]> code.ossystems Code Review - openembedded-core.git/commitdiff
nfs-utils: add x32 patch to fix nfsctl issue
authorSaul Wold <sgw@linux.intel.com>
Mon, 17 Sep 2012 17:58:06 +0000 (10:58 -0700)
committerSaul Wold <sgw@linux.intel.com>
Tue, 18 Sep 2012 14:44:13 +0000 (07:44 -0700)
nfsservctl syscall does not exist for x32, so return an error.

Signed-off-by: Saul Wold <sgw@linux.intel.com>
meta/recipes-connectivity/nfs-utils/nfs-utils/nfs-utils-nfsctl-x32-fix.patch [new file with mode: 0644]
meta/recipes-connectivity/nfs-utils/nfs-utils_1.2.3.bb

diff --git a/meta/recipes-connectivity/nfs-utils/nfs-utils/nfs-utils-nfsctl-x32-fix.patch b/meta/recipes-connectivity/nfs-utils/nfs-utils/nfs-utils-nfsctl-x32-fix.patch
new file mode 100644 (file)
index 0000000..26b4631
--- /dev/null
@@ -0,0 +1,30 @@
+
+Upstream-Status: Pending
+
+Signed-off-by: H.J. Lu <hjl.tools@gmail.com>
+
+--- nfs-utils-1.2.3/support/nfs/nfsctl.c.x32   2010-09-28 05:24:16.000000000 -0700
++++ nfs-utils-1.2.3/support/nfs/nfsctl.c       2011-11-30 13:34:09.369917161 -0800
+@@ -12,15 +12,22 @@
+ #include <unistd.h>
+ #include <asm/unistd.h>
++#include <errno.h>
+ #include "nfslib.h"
+ /* compatibility hack... */
+ #ifndef __NR_nfsctl
++#ifdef __NR_nfsservctl
+ #define __NR_nfsctl   __NR_nfsservctl
+ #endif
++#endif
+ int
+ nfsctl (int cmd, struct nfsctl_arg * argp, union nfsctl_res * resp)
+ {
++#ifdef __NR_nfsctl
+   return syscall (__NR_nfsctl, cmd, argp, resp);
++#else
++  return -ENOSYS;
++#endif
+ }
index eb18aaaa945ce7c9ad72fbf3253b6dd72e8617ca..5a4a7e7cbfa4e900823bea42a458146e23380c16 100644 (file)
@@ -12,11 +12,12 @@ DEPENDS = "libcap libnfsidmap libevent util-linux tcp-wrappers"
 RDEPENDS_${PN} = "portmap"
 RRECOMMENDS_${PN} = "kernel-module-nfsd"
 
-PR = "r4"
+PR = "r5"
 
 SRC_URI = "${SOURCEFORGE_MIRROR}/nfs/nfs-utils-${PV}.tar.bz2 \
            file://nfs-utils-1.0.6-uclibc.patch \
            file://nfs-utils-1.2.3-uclibc-libio.h.patch \
+           file://nfs-utils-nfsctl-x32-fix.patch \
            file://nfsserver"
 
 SRC_URI[md5sum] = "1131dc5f27c4f3905a6e7ee0d594fd4d"