]> code.ossystems Code Review - openembedded-core.git/commitdiff
python: don't wipe RDEPENDS when parsing manifest
authorRoss Burton <ross.burton@intel.com>
Mon, 15 Oct 2018 18:13:01 +0000 (19:13 +0100)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 15 Oct 2018 22:19:37 +0000 (23:19 +0100)
We want to allow the main recipe to extend RDEPENDS directly, so don't wipe
RDEPENDS when reading the manifest.

This fixes the missing python-misc dependency from python-modules.

As the wiping was having the good side-effect of removing the PN-dev dependency
on PN (which doesn't exist), clear RDEPENDS_${PN}-dev.

Signed-off-by: Ross Burton <ross.burton@intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-devtools/python/python3_3.5.6.bb
meta/recipes-devtools/python/python_2.7.15.bb

index 372f27b15dcdcaddaf91a272edd0ed7d7ffa73ec..72478f8663d2daeaecc34e36a3669c337944c23d 100644 (file)
@@ -245,6 +245,8 @@ FILES_${PN}-man = "${datadir}/man"
 
 RDEPENDS_${PN}-ptest = "${PN}-modules ${PN}-tests unzip bzip2"
 
+RDEPENDS_${PN}-dev = ""
+
 BBCLASSEXTEND = "nativesdk"
 
 RPROVIDES_${PN} += "${PN}-modules"
@@ -288,7 +290,6 @@ python(){
             for value in python_manifest[key]['cached']:
                     d.appendVar('FILES_' + pypackage, ' ' + value)
 
-        d.setVar('RDEPENDS_' + pypackage, '')
         for value in python_manifest[key]['rdepends']:
             # Make it work with or without $PN
             if '${PN}' in value:
index e3a4ddb32740a0bcdbc3cbff377e1f0e5bfcb42f..d78400b6e611af4df28f91ecbd8ca2311b2e1810 100644 (file)
@@ -177,6 +177,8 @@ FILES_${PN}-man = "${datadir}/man"
 # Nasty but if bdb isn't enabled the package won't be generated
 RDEPENDS_${PN}-modules_remove = "${@bb.utils.contains('PACKAGECONFIG', 'bdb', '', '${PN}-bsddb', d)}"
 
+RDEPENDS_${PN}-dev = ""
+
 BBCLASSEXTEND = "nativesdk"
 
 RPROVIDES_${PN} += "${PN}-modules"
@@ -220,7 +222,6 @@ python(){
                 if value.endswith('.py'):
                     d.appendVar('FILES_' + pypackage, ' ' + value + 'c')
 
-        d.setVar('RDEPENDS_' + pypackage, '')
         for value in python_manifest[key]['rdepends']:
             # Make it work with or without $PN
             if '${PN}' in value: