]> code.ossystems Code Review - openembedded-core.git/commitdiff
shared-mime-info: fix (sort of) upstream version check
authorAlexander Kanavin <alex.kanavin@gmail.com>
Wed, 29 Jan 2020 09:07:19 +0000 (10:07 +0100)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 3 Feb 2020 13:03:20 +0000 (13:03 +0000)
Upstream is using - to separate version components which
version checker at the moment can't deal with (i.e 1-15-1 when
1.15.1 is meant).

Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-support/shared-mime-info/shared-mime-info_git.bb

index f0d5bc62e9ed2fd36b4a7d52d88f86eba4b4b7ae..7a060b09ad9b091f5918ead71515198e705858ef 100644 (file)
@@ -12,6 +12,9 @@ SRCREV = "829b26d85e7d89a0caee03046c3bce373f04c80a"
 PV = "1.15"
 S = "${WORKDIR}/git"
 
+UPSTREAM_CHECK_GITTAGREGEX = "Release-(?P<pver>(\d+(\-\d+)+))"
+UPSTREAM_VERSION_UNKNOWN = "1"
+
 inherit autotools pkgconfig gettext python3native mime
 
 EXTRA_OECONF = "--disable-update-mimedb"