]> code.ossystems Code Review - openembedded-core.git/commitdiff
glib: fix Lithuanian strings in GDate test suite
authorRoss Burton <ross.burton@intel.com>
Tue, 9 Oct 2018 11:00:13 +0000 (12:00 +0100)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Wed, 10 Oct 2018 12:17:37 +0000 (13:17 +0100)
This test suite has hard-coded strings which don't match the new translations in
glibc 2.28, so update the test suite.

(From OE-Core rev: e1fa8611de2df3a1a15ae795c34f32e4e7fdbc79)

Signed-off-by: Ross Burton <ross.burton@intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-core/glib-2.0/glib-2.0/date-lt.patch [new file with mode: 0644]
meta/recipes-core/glib-2.0/glib-2.0_2.58.0.bb

diff --git a/meta/recipes-core/glib-2.0/glib-2.0/date-lt.patch b/meta/recipes-core/glib-2.0/glib-2.0/date-lt.patch
new file mode 100644 (file)
index 0000000..dd0aff7
--- /dev/null
@@ -0,0 +1,20 @@
+Update Lithuanian month names in the test suite as glibc changed the translations.
+
+Upstream-Status: Submitted [https://gitlab.gnome.org/GNOME/glib/merge_requests/373]
+Signed-off-by: Ross Burton <ross.burton@intel.com>
+
+diff --git a/glib/tests/date.c b/glib/tests/date.c
+index b801ca704..6646c227c 100644
+--- a/glib/tests/date.c
++++ b/glib/tests/date.c
+@@ -365,8 +365,8 @@ test_month_names (void)
+       TEST_DATE ( 1,  4, 2018,      "%Y m. %OB",      "2018 m. balandis");
+       TEST_DATE ( 1,  5, 2018,      "%Y m. %OB",        "2018 m. gegužė");
+       TEST_DATE ( 1,  6, 2018,      "%Y m. %OB",      "2018 m. birželis");
+-      TEST_DATE (17,  7, 2018, "%Y m. %b %e d.",     "2018 m. Lie 17 d.");
+-      TEST_DATE ( 1,  8, 2018,      "%Y m. %Ob",           "2018 m. Rgp");
++      TEST_DATE (17,  7, 2018, "%Y m. %b %e d.",   "2018 m. Liep. 17 d.");
++      TEST_DATE ( 1,  8, 2018,      "%Y m. %Ob",         "2018 m. rugp.");
+     }
+   else
+     g_test_skip ("locale lt_LT not available, skipping Lithuanian month names test");
index 6ebf1d2599440b5d5b8b6c32852c9beafd04e151..1271a7c269b9a663e3ec70dbae5db97694eca334 100644 (file)
@@ -13,6 +13,7 @@ SRC_URI = "${GNOME_MIRROR}/glib/${SHRT_VER}/glib-${PV}.tar.xz \
            file://0001-Install-gio-querymodules-as-libexec_PROGRAM.patch \
            file://0001-Do-not-ignore-return-value-of-write.patch \
            file://0010-Do-not-hardcode-python-path-into-various-tools.patch \
+           file://date-lt.patch \
            "
 
 SRC_URI_append_class-native = " file://relocate-modules.patch"