]> code.ossystems Code Review - openembedded-core.git/commitdiff
perl-native: Update for userelocatableinc and non-shared libperl
authorTom Rini <tom_rini@mentor.com>
Fri, 28 Jan 2011 21:07:21 +0000 (14:07 -0700)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Mon, 31 Jan 2011 16:29:50 +0000 (16:29 +0000)
Rather than using a wrapper switch to using upstreams support for
relocation.  While in here, bring in the mangling to use
/usr/bin/env perl rather than /full/path/to in order to work
in deep directory paths.

Also drop the DEPENDS on gpbm and db since we disable these in the configure
and don't use them.

Signed-off-by: Tom Rini <tom_rini@mentor.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-devtools/perl/perl-native_5.12.2.bb

index 14da569ba76c8992734327905e7b51f877f63dbc..a634da5c2340a744bf327e7eb315eb657bdadc81 100644 (file)
@@ -4,8 +4,7 @@ SECTION = "libs"
 LICENSE = "Artistic|GPL"
 LIC_FILES_CHKSUM = "file://Copying;md5=2b4c6ffbcfcbdee469f02565f253d81a \
                    file://Artistic;md5=f921793d03cc6d63ec4b15e9be8fd3f8"
-DEPENDS = "virtual/db-native gdbm-native"
-PR = "r2"
+PR = "r3"
 
 LIC_FILES_CHKSUM = "file://Copying;md5=2b4c6ffbcfcbdee469f02565f253d81a \
                     file://Artistic;md5=f921793d03cc6d63ec4b15e9be8fd3f8"
@@ -29,19 +28,21 @@ do_configure () {
                -Dcflags="${CFLAGS}" \
                -Dldflags="${LDFLAGS}" \
                -Dcf_by="Open Embedded" \
+               \
                -Dprefix=${prefix} \
                -Dvendorprefix=${prefix} \
                -Dvendorprefix=${prefix} \
                -Dsiteprefix=${prefix} \
                \
-               -Dprivlib=${STAGING_LIBDIR}/perl/${PV} \
-               -Darchlib=${STAGING_LIBDIR}/perl/${PV} \
-               -Dvendorlib=${STAGING_LIBDIR}/perl/${PV} \
-               -Dvendorarch=${STAGING_LIBDIR}/perl/${PV} \
-               -Dsitelib=${STAGING_LIBDIR}/perl/${PV} \
-               -Dsitearch=${STAGING_LIBDIR}/perl/${PV} \
+               -Dprivlib=.../../lib/perl/${PV} \
+               -Darchlib=.../../lib/perl/${PV} \
+               -Dvendorlib=.../../lib/perl/${PV} \
+               -Dvendorarch=.../../lib/perl/${PV} \
+               -Dsitelib=.../../lib/perl/${PV} \
+               -Dsitearch=.../../lib/perl/${PV} \
+               -Duserelocatableinc="y" \
                \
-               -Duseshrplib \
+               -Uuseshrplib \
                -Dusethreads \
                -Duseithreads \
                -Duselargefiles \
@@ -89,8 +90,12 @@ do_install () {
                install $i ${D}${libdir}/perl/${PV}/CORE
        done
 
-       create_wrapper ${D}${bindir}/perl PERL5LIB='$PERL5LIB:${STAGING_LIBDIR}/perl/5.12.2:${STAGING_LIBDIR}/perl/'
+       # Make sure we use /usr/bin/env perl
+       for PERLSCRIPT in `grep -rIEl '#!.*/perl' ${D}${bindir}`; do
+               sed -i -e '1s|^#!.*|#!/usr/bin/env perl|' $PERLSCRIPT
+       done
 }
+
 do_install_append_nylon() {
        # get rid of definitions not supported by the gcc version we use for nylon...
        for i in ${D}${libdir}/perl/${PV}/Config_heavy.pl ${D}${libdir}/perl/config.sh; do