]> code.ossystems Code Review - openembedded-core.git/commitdiff
busybox: fix ptest failure about 'dc'
authorChen Qi <Qi.Chen@windriver.com>
Wed, 17 Apr 2019 03:18:51 +0000 (11:18 +0800)
committerArmin Kuster <akuster808@gmail.com>
Thu, 2 May 2019 20:23:40 +0000 (13:23 -0700)
Fix the following two failure of busybox ptest:

  FAIL: dc read
  FAIL: dc read string

These two test cases relies on the functionalities enabled by
CONFIG_FEATURE_DC_BIG.

Signed-off-by: Chen Qi <Qi.Chen@windriver.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Signed-off-by: Armin Kuster <akuster808@gmail.com>
meta/recipes-core/busybox/busybox/0001-dc.tests-fix-two-test-case-to-also-depend-on-DC_BIG.patch [new file with mode: 0644]
meta/recipes-core/busybox/busybox_1.30.1.bb

diff --git a/meta/recipes-core/busybox/busybox/0001-dc.tests-fix-two-test-case-to-also-depend-on-DC_BIG.patch b/meta/recipes-core/busybox/busybox/0001-dc.tests-fix-two-test-case-to-also-depend-on-DC_BIG.patch
new file mode 100644 (file)
index 0000000..d22db4a
--- /dev/null
@@ -0,0 +1,39 @@
+From a4e03fbb4d82f91069d96005405f89c45b8fd157 Mon Sep 17 00:00:00 2001
+From: Chen Qi <Qi.Chen@windriver.com>
+Date: Wed, 17 Apr 2019 09:24:37 +0800
+Subject: [PATCH] dc.tests: fix two test case to also depend on DC_BIG
+
+Upstream-Status: Submitted [http://lists.busybox.net/pipermail/busybox/2019-April/087205.html]
+
+Signed-off-by: Chen Qi <Qi.Chen@windriver.com>
+---
+ testsuite/dc.tests | 6 +++---
+ 1 file changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/testsuite/dc.tests b/testsuite/dc.tests
+index 1708a48..8c3af41 100755
+--- a/testsuite/dc.tests
++++ b/testsuite/dc.tests
+@@ -41,6 +41,9 @@ testing "dc complex without spaces (multiple args)" \
+       "16\n" \
+       "" ""
++optional FEATURE_DC_BIG
++# All tests below depend on FEATURE_DC_BIG
++
+ testing "dc read" \
+       "dc -finput" \
+       "2\n9\n1\n" \
+@@ -51,9 +54,6 @@ testing "dc read string" \
+       "2\nstr\n1\n" \
+       "1?2\nf" "[str]\n"
+-optional FEATURE_DC_BIG
+-# All tests below depend on FEATURE_DC_BIG
+-
+ testing "dc '>a' (conditional execute string) 1" \
+       "dc" \
+       "1\n9\n" \
+-- 
+2.7.4
+
index 164f3ab3c3f3e95257703f494f6b1ebb9ab34785..ba76755d74fcda0335b77dec0acdec9f0d1f56fb 100644 (file)
@@ -44,6 +44,7 @@ SRC_URI = "http://www.busybox.net/downloads/busybox-${PV}.tar.bz2;name=tarball \
            file://0001-testsuite-check-uudecode-before-using-it.patch \
            file://0001-testsuite-use-www.example.org-for-wget-test-cases.patch \
            file://0001-du-l-works-fix-to-use-145-instead-of-144.patch \
+           file://0001-dc.tests-fix-two-test-case-to-also-depend-on-DC_BIG.patch \
 "
 SRC_URI_append_libc-musl = " file://musl.cfg "