]> code.ossystems Code Review - openembedded-core.git/commitdiff
libical: Pass TOOLCHAIN_OPTIONS via CFLAGS
authorKhem Raj <raj.khem@gmail.com>
Tue, 1 Mar 2022 04:13:46 +0000 (20:13 -0800)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Fri, 4 Mar 2022 17:13:10 +0000 (17:13 +0000)
This ensures that right sysroot is used during build, otherwise we see
warnings in build about using wrong sysroot and it fails explicitly with
clang

x86_64-yoe-linux-ld: warning: library search path "/usr/lib/gcc/x86_6
4-pc-linux-gnu/11.2.0/../../../../lib64" is unsafe for cross-compilation

x86_64-yoe-linux-ld: cannot find /usr/lib/clang/14.0.0/lib/linux/libc
lang_rt.builtins-x86_64.a: No such file or directory

Signed-off-by: Khem Raj <raj.khem@gmail.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-support/libical/libical_3.0.14.bb

index 717eb11e125465b60f0da84efbff906da9bf8e9a..879ad8ed59581c99b3e95f3862469b13375cc809 100644 (file)
@@ -18,6 +18,8 @@ UPSTREAM_CHECK_URI = "https://github.com/libical/libical/releases"
 
 inherit cmake pkgconfig gobject-introspection vala
 
+CFLAGS += "${TOOLCHAIN_OPTIONS}"
+
 DEPENDS += "libical-native"
 
 PACKAGECONFIG ??= "icu glib"