]> code.ossystems Code Review - openembedded-core.git/commitdiff
tcl: use tcl-core instead of patching out packages
authorRoss Burton <ross.burton@arm.com>
Fri, 9 Jul 2021 16:03:53 +0000 (17:03 +0100)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Tue, 13 Jul 2021 13:24:47 +0000 (14:24 +0100)
Instead of patching out the build of optional packages, we can just use
the tcl-core tarball which is identical except it doesn't include the
packages.

Signed-off-by: Ross Burton <ross.burton@arm.com>
meta/recipes-devtools/tcltk/tcl/no_packages.patch [deleted file]
meta/recipes-devtools/tcltk/tcl_8.6.11.bb

diff --git a/meta/recipes-devtools/tcltk/tcl/no_packages.patch b/meta/recipes-devtools/tcltk/tcl/no_packages.patch
deleted file mode 100644 (file)
index 5c622a2..0000000
+++ /dev/null
@@ -1,53 +0,0 @@
-tcl 8.6.0 builds by default a number of packages that are not needed in Yocto.
-This patch changes the makefile so that these packages are not built by default.
-
-Upstream-Status:Inappropriate [embedded specific]
-
-Signed-off-by: Bogdan Marinescu <bogdan.a.marinescu@intel.com>
-
-diff --git a/Makefile.in b/Makefile.in
-index b729ffd..2c2e824 100644
---- a/Makefile.in
-+++ b/Makefile.in
-@@ -612,7 +612,7 @@ SRCS = $(GENERIC_SRCS) $(TOMMATH_SRCS) $(UNIX_SRCS) $(NOTIFY_SRCS) \
- # Start of rules
- #--------------------------------------------------------------------------
--all: binaries libraries doc packages
-+all: binaries libraries doc
- binaries: ${LIB_FILE} ${TCL_EXE}
-@@ -656,12 +656,12 @@ Makefile: $(UNIX_DIR)/Makefile.in $(DLTEST_DIR)/Makefile.in
- #tclConfig.h: $(UNIX_DIR)/tclConfig.h.in
- #     $(SHELL) config.status
--clean: clean-packages
-+clean:
-       rm -rf *.a *.o libtcl* core errs *~ \#* TAGS *.E a.out \
-               errors ${TCL_EXE} ${TCLTEST_EXE} lib.exp Tcl @DTRACE_HDR@
-       cd dltest ; $(MAKE) clean
--distclean: distclean-packages clean
-+distclean: clean
-       rm -rf Makefile config.status config.cache config.log tclConfig.sh \
-               tclConfig.h *.plist Tcl.framework tcl.pc
-       cd dltest ; $(MAKE) distclean
-@@ -709,7 +709,7 @@ tcltest-real:
- # tcltest, ie:
- #     % make test TESTFLAGS="-verbose bps -file fileName.test"
--test: test-tcl test-packages
-+test: test-tcl
- test-tcl: ${TCLTEST_EXE}
-       $(SHELL_ENV) ${TCLTEST_EXE} $(TOP_DIR)/tests/all.tcl $(TESTFLAGS)
-@@ -774,7 +774,7 @@ INSTALL_PACKAGE_TARGETS = install-packages
- INSTALL_DEV_TARGETS = install-headers
- INSTALL_EXTRA_TARGETS = @EXTRA_INSTALL@
- INSTALL_TARGETS = $(INSTALL_BASE_TARGETS) $(INSTALL_DOC_TARGETS) $(INSTALL_DEV_TARGETS) \
--                $(INSTALL_PACKAGE_TARGETS) $(INSTALL_EXTRA_TARGETS)
-+                $(INSTALL_EXTRA_TARGETS)
- install: $(INSTALL_TARGETS)
index b2863f9a1f99e2202761e96ea3ea35306eab7165..722e4a0132847a233e5aa45086bd29a8b1f69ed3 100644 (file)
@@ -15,17 +15,16 @@ LIC_FILES_CHKSUM = "file://../license.terms;md5=058f6229798281bbcac4239c788cfa38
 
 DEPENDS = "tcl-native zlib"
 
-BASE_SRC_URI = "${SOURCEFORGE_MIRROR}/tcl/${BPN}${PV}-src.tar.gz \
+BASE_SRC_URI = "${SOURCEFORGE_MIRROR}/tcl/tcl-core${PV}-src.tar.gz \
                 file://tcl-add-soname.patch"
 SRC_URI = "${BASE_SRC_URI} \
            file://fix_non_native_build_issue.patch \
            file://fix_issue_with_old_distro_glibc.patch \
-           file://no_packages.patch \
            file://tcl-remove-hardcoded-install-path.patch \
            file://alter-includedir.patch \
            file://run-ptest \
 "
-SRC_URI[sha256sum] = "8c0486668586672c5693d7d95817cb05a18c5ecca2f40e2836b9578064088258"
+SRC_URI[sha256sum] = "cfb49aab82bd179651e23eeeb69606f51b0ddc575ca55c3d35e2457469024cfa"
 
 SRC_URI_class-native = "${BASE_SRC_URI}"