]> code.ossystems Code Review - openembedded-core.git/commitdiff
apt: revert the dso_linking_change patch as the new linker fixes it
authorNitin A Kamble <nitin.a.kamble@intel.com>
Fri, 21 Jan 2011 17:52:23 +0000 (09:52 -0800)
committerSaul Wold <sgw@linux.intel.com>
Mon, 24 Jan 2011 22:09:12 +0000 (14:09 -0800)
The newer binutils recipe of version 2.21 has a fix for ld which avoids an
issue where weak symbols like pthread_cancel were causing linking to fail wh
--no-add-as-needed parameter was passed to ld.

See more information here: http://bugs.debian.org/591405

This makes some of the fixes for breakage after gcc dso linking change
unnecessary and this is one of them.

Signed-off-by: Nitin A Kamble <nitin.a.kamble@intel.com>
meta/recipes-devtools/apt/apt-0.7.14/dso_linking_change_build_fix.patch [deleted file]
meta/recipes-devtools/apt/apt_0.7.14.bb

diff --git a/meta/recipes-devtools/apt/apt-0.7.14/dso_linking_change_build_fix.patch b/meta/recipes-devtools/apt/apt-0.7.14/dso_linking_change_build_fix.patch
deleted file mode 100644 (file)
index b69849f..0000000
+++ /dev/null
@@ -1,25 +0,0 @@
-after gcc linking has changed, all the libraries must be explicitely specified 
-This patch avoids these linking errors:
-
-Building program /build_disk/poky_build/build0/tmp/work/i586-poky-linux/apt-0.7.14-r4/apt-0.7.14/bin/methods/https
-/build_disk/poky_build/build0/tmp/sysroots/x86_64-linux/usr/libexec/i586-poky-linux/gcc/i586-poky-linux/4.5.1/ld: <86>: invalid DSO for symbol `pthread_cancel@@GLIBC_2.0' definition
-/build_disk/poky_build/build0/tmp/sysroots/i586-poky-linux/lib/libpthread.so.0: could not read symbols: Bad value
-collect2: ld returned 1 exit status
-make[2]: *** [/build_disk/poky_build/build0/tmp/work/i586-poky-linux/apt-0.7.14-r4/apt-0.7.14/bin/methods/https] Error 1
-
-Nitin A Kamble <nitin.a.kamble@intel.com>
-Date: 2011/01/19
-
-Index: apt-0.7.14/methods/makefile
-===================================================================
---- apt-0.7.14.orig/methods/makefile   2008-05-28 06:22:14.000000000 -0700
-+++ apt-0.7.14/methods/makefile        2011-01-19 16:30:07.369010214 -0800
-@@ -54,7 +54,7 @@
- # The https method
- PROGRAM=https
--SLIBS = -lapt-pkg -lcurl
-+SLIBS = -lapt-pkg -lcurl -lpthread
- LIB_MAKES = apt-pkg/makefile
- SOURCE = https.cc
- include $(PROGRAM_H)
index b9b278b17c9240d775c2bf0c13dad4bf2e8b935c..aa155d9d475b1955bfe180df8e62ed8303850692 100644 (file)
@@ -3,11 +3,10 @@ RDEPENDS_${PN} = "dpkg"
 LIC_FILES_CHKSUM = "file://COPYING.GPL;md5=0636e73ff0215e8d672dc4c32c317bb3"
 require apt.inc
 
-PR = "r5"
+PR = "r6"
 
 SRC_URI += "file://nodoc.patch \
-           file://includes-fix.patch \
-           file://dso_linking_change_build_fix.patch "
+           file://includes-fix.patch "
 
 SRC_URI[md5sum] = "19efa18fb1ef20c58b9b44e94258b814"
 SRC_URI[sha256sum] = "8fc06effaf8a4e4333308eedcdc6840f1c8056f2e924210f151dfc076bcd4045"