]> code.ossystems Code Review - openembedded-core.git/commitdiff
cve-update-db-native: handle all-wildcard versions
authorRoss Burton <ross@burtonini.com>
Tue, 24 Nov 2020 12:57:24 +0000 (12:57 +0000)
committerSteve Sakoman <steve@sakoman.com>
Thu, 10 Dec 2020 14:11:06 +0000 (04:11 -1000)
If a CPE version field is just *:*:*:* it should be handled the same as
-:*:*:*, that is 'all versions'.  To ease handling, transform this case
to use -.

Signed-off-by: Ross Burton <ross.burton@arm.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
(cherry picked from commit 04a9bc4ca5294fe6834513669c7746a824d12b04)
Signed-off-by: Steve Sakoman <steve@sakoman.com>
meta/recipes-core/meta/cve-update-db-native.bb

index 0cd3a1c1534c9f6600f7fe28755f826649d006a3..9e8e006a32c510a4259bcb5bcef36b9417448d70 100644 (file)
@@ -166,7 +166,12 @@ def parse_node_and_insert(c, node, cveId):
                     op_end = '<'
                     v_end = cpe['versionEndExcluding']
 
-                yield [cveId, vendor, product, v_start, op_start, v_end, op_end]
+                if op_start or op_end or v_start or v_end:
+                    yield [cveId, vendor, product, v_start, op_start, v_end, op_end]
+                else:
+                    # This is no version information, expressed differently.
+                    # Save processing by representing as -.
+                    yield [cveId, vendor, product, '-', '', '', '']
 
     c.executemany("insert into PRODUCTS values (?, ?, ?, ?, ?, ?, ?)", cpe_generator())