]> code.ossystems Code Review - openembedded-core.git/commitdiff
python3: remove 2to3 symlink from package python3-2to3
authorDominic Sacré <dominic.sacre@gmx.de>
Tue, 28 Jul 2015 14:58:37 +0000 (16:58 +0200)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Sat, 1 Aug 2015 09:59:26 +0000 (10:59 +0100)
The 2to3 symlink conflicts with its Python 2 equivalent in package
python-2to3.
The Python 3 version of the tool is still available as 2to3-3.4.

Signed-off-by: Dominic Sacré <dominic.sacre@gmx.de>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-devtools/python/python-3.4-manifest.inc
meta/recipes-devtools/python/python3_3.4.3.bb
scripts/contrib/python/generate-manifest-3.4.py

index 77f01254e2f92b3875c0b2d217451db6bfdb35b1..07e149027319189a3c6a3aad304f3b733638d537 100644 (file)
@@ -11,7 +11,7 @@ PACKAGES="${PN}-dbg ${PN}-2to3 ${PN}-asyncio ${PN}-audio ${PN}-codecs ${PN}-comp
 
 SUMMARY_${PN}-2to3="Python automated Python 2 to 3 code translator"
 RDEPENDS_${PN}-2to3="${PN}-core"
-FILES_${PN}-2to3="${bindir}/2to3 ${libdir}/python3.4/lib2to3 "
+FILES_${PN}-2to3="${libdir}/python3.4/lib2to3 "
 
 SUMMARY_${PN}-asyncio="Python Asynchronous I/O, event loop, coroutines and tasks"
 RDEPENDS_${PN}-asyncio="${PN}-core"
index e2d9f796f1114db7b673e11103ef0ef79ff61175..6c2e21d6a9c29f338d295a34dd6f5221b6de4a45 100644 (file)
@@ -162,6 +162,9 @@ do_install() {
                ARCH=${TARGET_ARCH} \
                DESTDIR=${D} LIBDIR=${libdir} install
 
+       # avoid conflict with 2to3 from Python 2
+       rm -f ${D}/${bindir}/2to3
+
        install -m 0644 Makefile.sysroot ${D}/${libdir}/python${PYTHON_MAJMIN}/config/Makefile
 
        if [ -e ${WORKDIR}/sitecustomize.py ]; then
index 42c851c11a07b3a74b8fc468d898b5b476de75db..06eecdc5d0d5f300d0e32a1845b8e0a175ea1267 100755 (executable)
@@ -194,7 +194,7 @@ if __name__ == "__main__":
     "${datadir}/pkgconfig " )
 
     m.addPackage( "${PN}-2to3", "Python automated Python 2 to 3 code translator", "${PN}-core",
-    "${bindir}/2to3 lib2to3" ) # package
+    "lib2to3" ) # package
 
     m.addPackage( "${PN}-idle", "Python Integrated Development Environment", "${PN}-core ${PN}-tkinter",
     "${bindir}/idle idlelib" ) # package