Upstream-Status: Pending
---
- Makefile.org | 10 +-
- Makefile.org.orig | 7 +-
- test/Makefile | 13 +-
- test/Makefile.orig | 987 +++++++++++++++++++++++++++++++++++++++++++++++++++++
- 4 files changed, 1009 insertions(+), 8 deletions(-)
- create mode 100644 test/Makefile.orig
-
+ Makefile.org | 10 +++++++++-
+ test/Makefile | 13 +++++++++----
+ 2 files changed, 18 insertions(+), 5 deletions(-)
+
diff --git a/Makefile.org b/Makefile.org
index 111fbba..8e7936c 100644
--- a/Makefile.org
+++ b/Makefile.org
-@@ -468,8 +468,16 @@ rehash.time: certs apps
+@@ -467,8 +467,16 @@ rehash.time: certs apps
test: tests
tests: rehash
report:
diff --git a/test/Makefile b/test/Makefile
-index a1f7eeb..b2984c4 100644
+index 55a6b50..d46b4d1 100644
--- a/test/Makefile
+++ b/test/Makefile
@@ -150,7 +150,7 @@ tests: exe apps $(TESTS)
test_rmd test_rc2 test_rc4 test_rc5 test_bf test_cast test_aes \
@@ -162,6 +162,11 @@ alltests: \
test_constant_time test_verify_extra test_clienthello test_sslv2conftest \
- test_dtls test_bad_dtls test_fatalerr
+ test_dtls test_bad_dtls test_fatalerr test_x509_time
+alltests:
+ @(for i in $(all-tests); do \
--
2.15.1
-
Signed-off-by: Patrick Ohly <patrick.ohly@intel.com>
---
- Makefile.org | 14 +-
- Makefile.org.orig | 10 +-
- Makefile.shared | 2 +
- Makefile.shared.orig | 655 ++++++++++++++++++++++++++++++++++++++++++++++++++
- crypto/Makefile | 10 +-
- engines/Makefile | 6 +-
- engines/Makefile.orig | 338 ++++++++++++++++++++++++++
- test/Makefile | 92 +++----
- test/Makefile.orig | 88 ++++---
- 9 files changed, 1108 insertions(+), 107 deletions(-)
- create mode 100644 Makefile.shared.orig
- create mode 100644 engines/Makefile.orig
+ Makefile.org | 14 ++--
+ Makefile.shared | 2 +
+ crypto/Makefile | 10 +--
+ engines/Makefile | 6 +-
+ test/Makefile | 94 +++++++++++-----------
+ 5 files changed, 64 insertions(+), 62 deletions(-)
diff --git a/Makefile.org b/Makefile.org
-index 8e7936c..ed98d2a 100644
+index efcfafb..82eab91 100644
--- a/Makefile.org
+++ b/Makefile.org
-@@ -283,17 +283,17 @@ build_libcrypto: build_crypto build_engines libcrypto.pc
+@@ -282,17 +282,17 @@ build_libcrypto: build_crypto build_engines libcrypto.pc
build_libssl: build_ssl libssl.pc
build_crypto:
all_testapps: build_libs build_testapps
build_testapps:
-@@ -565,7 +565,7 @@ install_sw:
+@@ -564,7 +564,7 @@ install_sw:
(cp $$i $(INSTALL_PREFIX)$(INSTALLTOP)/include/openssl/$$i; \
chmod 644 $(INSTALL_PREFIX)$(INSTALLTOP)/include/openssl/$$i ); \
done;
do \
if [ -f "$$i" ]; then \
diff --git a/Makefile.shared b/Makefile.shared
-index f6f92e7..8164186 100644
+index bbefb2b..18013a9 100644
--- a/Makefile.shared
+++ b/Makefile.shared
@@ -105,6 +105,7 @@ LINK_SO= \
ln -s $$prev $$SHLIB$$SHLIB_SUFFIX ); \
fi; \
diff --git a/crypto/Makefile b/crypto/Makefile
-index 17a87f8..29c2dcf 100644
+index 875ea1a..c22b683 100644
--- a/crypto/Makefile
+++ b/crypto/Makefile
@@ -85,11 +85,11 @@ testapps:
tags:
ctags $(SRC)
diff --git a/test/Makefile b/test/Makefile
-index 40abd60..78d3788 100644
+index 36506cf..c69af8b 100644
--- a/test/Makefile
+++ b/test/Makefile
@@ -145,7 +145,7 @@ install:
apps:
@(cd ..; $(MAKE) DIRS=apps all)
-@@ -444,139 +444,139 @@ BUILD_CMD_STATIC=shlib_target=; \
+@@ -448,142 +448,142 @@ BUILD_CMD_STATIC=shlib_target=; \
link_app.$${shlib_target}
$(RSATEST)$(EXE_EXT): $(RSATEST).o $(DLIBCRYPTO)
$(FATALERRTEST)$(EXE_EXT): $(FATALERRTEST).o ssltestlib.o $(DLIBSSL) $(DLIBCRYPTO)
@target=$(FATALERRTEST); exobj=ssltestlib.o; $(BUILD_CMD)
-
+
+ $(X509TIMETEST)$(EXE_EXT): $(X509TIMETEST).o
+- @target=$(X509TIMETEST) $(BUILD_CMD)
++ +@target=$(X509TIMETEST) $(BUILD_CMD)
+
$(SSLV2CONFTEST)$(EXE_EXT): $(SSLV2CONFTEST).o
- @target=$(SSLV2CONFTEST) $(BUILD_CMD)
+ +@target=$(SSLV2CONFTEST) $(BUILD_CMD)
#$(AESTEST).o: $(AESTEST).c
# $(CC) -c $(CFLAGS) -DINTERMEDIATE_VALUE_KAT -DTRACE_KAT_MCT $(AESTEST).c
-@@ -589,7 +589,7 @@ $(DTLSTEST)$(EXE_EXT): $(DTLSTEST).o ssltestlib.o $(DLIBSSL) $(DLIBCRYPTO)
+@@ -596,7 +596,7 @@ $(DTLSTEST)$(EXE_EXT): $(DTLSTEST).o ssltestlib.o $(DLIBSSL) $(DLIBCRYPTO)
# fi
dummytest$(EXE_EXT): dummytest.o $(DLIBCRYPTO)