]> code.ossystems Code Review - openembedded-core.git/commitdiff
Re-arrange packaging and stage the headers
authorRoss Burton <ross@openedhand.com>
Wed, 24 Jan 2007 10:38:47 +0000 (10:38 +0000)
committerRoss Burton <ross@openedhand.com>
Wed, 24 Jan 2007 10:38:47 +0000 (10:38 +0000)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@1198 311d38ba-8fff-0310-9ca6-ca027cbcb966

meta/packages/matchbox-panel-2/matchbox-panel-2_svn.bb

index 82dc31c4592426e6f78fbc84b62c8bc6f15433ca..f2854c0833d401b9524dc54c2384c6b6667c42fb 100644 (file)
@@ -3,6 +3,7 @@ PRIORITY = "optional"
 MAINTAINER = "Chris Lord <chris@openedhand.com>"
 PV = "0.0+svn${SRCDATE}"
 DEPENDS = "gtk+ startup-notification apmd"
+PR = "r1"
 
 SRC_URI = "svn://svn.o-hand.com/repos/matchbox/trunk;module=${PN};proto=http"
 
@@ -10,10 +11,12 @@ EXTRA_OECONF = "--enable-startup-notification --disable-libnotify"
 
 S = ${WORKDIR}/${PN}
 
-FILES_${PN} += "${libdir}/matchbox-panel/*.so.* \
+FILES_${PN} += "${libdir}/matchbox-panel/*.so \
                 ${datadir}/matchbox-panel/battery/*.png"
-FILES_${PN}-dev += "${libdir}/matchbox-panel/*.so ${libdir}/matchbox-panel/*.la \
-                  ${libdir}/matchbox-panel/*.a"
+FILES_${PN}-dbg += "${libdir}/matchbox-panel/.debug"
 
 inherit autotools pkgconfig
 
+do_stage() {
+        autotools_stage_all
+}