]> code.ossystems Code Review - openembedded-core.git/commitdiff
base-files: filesystems: fix mount order
authorGary Thomas <gary@mlbassoc.com>
Fri, 6 Jan 2012 13:35:54 +0000 (06:35 -0700)
committerRichard Purdie <richard.purdie@linuxfoundation.org>
Fri, 6 Jan 2012 14:41:19 +0000 (14:41 +0000)
This changes the order that file system [types] are tried
when using 'mount' in busybox when the file system type is
not explictly specified.  The pervious ordering is
incorrect in that less capable file system types are tried
first, e.g. ext2 before ext3, which will cause an ext3 file
system to be mounted as ext2, disabling some of the ext3
features such as journaling.

The change also moves infrequently used file system types to
the end as checking for them is just a waste of effort in
most cases.  The list now also includes ext4.

[RP: Add PR bump, unbreak patch application]
Signed-off-by: Gary Thomas <gary@mlbassoc.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
meta/recipes-core/base-files/base-files/filesystems
meta/recipes-core/base-files/base-files_3.0.14.bb

index 2af6a7e3557ccb0bde9ed14e0e8a7dcb0c8332ce..7e6c41c38f61faa2aa495002324f4fabb6aba9e2 100644 (file)
@@ -1,7 +1,8 @@
-minix
-fat
-vfat
-ext2
+ext4
 ext3
+ext2
+vfat
+fat
 btrfs
+minix
 *
index eb40917eb56bbb5fc41228ea25df2f7a53b77c5f..6bab040e4f76d3a79d71de24108381d95cc563eb 100644 (file)
@@ -1,7 +1,7 @@
 SUMMARY = "Miscellaneous files for the base system."
 DESCRIPTION = "The base-files package creates the basic system directory structure and provides a small set of key configuration files for the system."
 SECTION = "base"
-PR = "r70"
+PR = "r71"
 LICENSE = "GPLv2"
 LIC_FILES_CHKSUM = "file://licenses/GPL-2;md5=94d55d512a9ba36caa9b7df079bae19f"
 # Removed all license related tasks in this recipe as license.bbclass