From: Li Zhou
Date: Thu, 30 Jul 2015 05:20:23 +0000 (+0800)
Subject: tzdata: Add marking for config files in recipe
X-Git-Tag: 2015-10~1017
X-Git-Url: https://code.ossystems.io/gitweb?a=commitdiff_plain;h=1eefbf6bdf5e720767673a754e95c62f2ffcc82f;p=openembedded-core.git
tzdata: Add marking for config files in recipe
The tzdata recipe does not mark the /etc/timezone file and
/etc/localtime link as configuration files. An on target update would
then overwite the user modified versions of those files.
Add those files in CONFFILES_${PN}.
Signed-off-by: Li Zhou
Signed-off-by: Ross Burton
---
diff --git a/meta/recipes-extended/tzdata/tzdata_2015e.bb b/meta/recipes-extended/tzdata/tzdata_2015e.bb
index 9179d7be4f..92389a95c8 100644
--- a/meta/recipes-extended/tzdata/tzdata_2015e.bb
+++ b/meta/recipes-extended/tzdata/tzdata_2015e.bb
@@ -203,3 +203,5 @@ FILES_${PN} += "${datadir}/zoneinfo/Pacific/Honolulu \
${datadir}/zoneinfo/zone.tab \
${datadir}/zoneinfo/iso3166.tab \
${datadir}/zoneinfo/Etc/*"
+
+CONFFILES_${PN} += "${sysconfdir}/timezone ${sysconfdir}/localtime"